FastTrack Schedule 10

Tutorials Manual

Copyright © 2010, AEC Software, Inc. All rights reserved.



FastTrack Schedule Documentation
Version 10.0.0

by Carol S. Williamson

AEC Software, Inc.

With FastTrack Schedule 10, the new version of the award-winning project manager, it’s
easier than ever to plan and manage your projects.

Powerful tracking tools and dynamic status reports keep team members in sync, costs
under control, and projects on schedule.



FastTrack Schedule 10 Tutorials Manual

Copyright © 2010, AEC Software, Inc. All rights reserved.

All rights reserved. No parts of this work may be reproduced in any form or by any means - graphic, electronic, or
mechanical, including photocopying, recording, taping, or information storage and retrieval systems - without the
written permission of the publisher.

Products that are referred to in this document may be either trademarks and/or registered trademarks of the
respective owners. The publisher and the author make no claim to these trademarks.

While every precaution has been taken in the preparation of this document, the publisher and the author assume no
responsibility for errors or omissions, or for damages resulting from the use of information contained in this
document or from the use of programs and source code that may accompany it. In no event shall the publisher and
the author be liable for any loss of profit or any other commercial damage caused or alleged to have been caused
directly or indirectly by this document.

Prepared October, 2010 in Dulles, Virginia, USA

Publisher
AEC Software, Inc.

Managing Editor

Carol S. Williamson

Technical Editor
Kalvin K. Saccal

Art Designer
The Bigger Design

Special thanks to:

All the people who contributed to this document, to all current and
previous AEC Software family members who inspire and create great
products, and to all partners and associates of AEC Software.



4 FastTrack Schedule 10 Tutorials Manual

Table of Contents

Chapter 1 Tutorials 8
Chapter 2 Using the Tutorials 8
Chapter 3 Printing the Tutorials 9
Chapter 4 Tutorial 1: Up and Running 10
1 Up and.RUNNING. 2 INErO. ... oo s s e s s s e s s s s s easnnnnnns 10

2 The FastIrack.Schedule.enviranment..............coooiiiiiiiiiiii e 10

BT (- T I e T 11

4 Viewing the.schedule...........cooiiiiiiiiiii 12

5 Creating.aCtiVities.......ccuiiiniieiii e e nenas 13

L T T T T o T 13

T TYPING.AAtes. .. oo e na 14

8 Drawing.milestones.........ccuiiiiuiiiiiiiiii i 15

L T 0 - Yo o 11 Vo N o T- 1 -7 PPN 15

10 Changing.the.schedule.date.range.......cccooi i e e e e e et i e sen s e sennns 16

11 Typing.to.change.dates. ...t e e 16

12 Printing.the.schedule............coo e 17

13 Printing.the.schedule.in.Calendar. Mi@W............ooouiimiiiiii e e 17

14 Finishing. TULOrial ... ..ot e e e s e rra s rra s rn e e n e en s enssnansnansnasnnnnmasnmnnnnn s 19
Chapter 5 Tutorial 2: Laying Out Your Schedule 20
1 Laying.Qut.Yaur.Schedule.-.Intro............cooiiiiiiiiiiii i 20

2 Indenting .OULLNE. LENVEIS. ...t e e e e e e s s s s s e e e s e s e e e ran s r e n e nan e aaen 20

3 Collapsing. OUlINE. JENEIS .....ciin e e e e na e na e nannns 21

4 Expanding.outline. leVels.............ooiiiieiiiiiiiii e 22

5 Viewinga different.layOut...........ccooiiimiiiiiimiiii i 22

LS 1 o= Yo T oo ] [ H] 4T ¢ =P 23

7 Formatting.COLUMNS. ...couuiieii it e e e e e e e e e e e e s e e s e e s e e e n s remnas 24

8 Designing.a.neM.layQuUL............coouiiiiiiii e 25

9 Designing.a.nem.layaut.(Cont'd)..........oviiimuiiiiii i 26

10 Inserting.and.formatting timescale LOWS.......c..ccoiiiiiiii e e e e e e e e e e e en s enneenn s 27

11 MoOVING.tiMESCAIE. FOMS. ... iuieiiiiie e et e e e s e eraseasna s rnasrn s nnssnnnsnansnassnassnasnnasnnnsnnnns 28

12 Resizing.the.timeline:Calumns..............coiiuiiiiiiii e 29

13 Finishing.Tutorial.2...........cooree i 29

Copyright © 2010, AEC Software, Inc. All rights reserved.



Contents 5

Chapter 6 Tutorial 3: Customizing Your Schedule 30
1 Customizing.Your.Schedule.~Intro...........ccoovmiiiiiiiiii s 30

2 Formatting.bar.styles........ccoooiiiii 30

3 Designing.the.bar elements...........cooiiiiiiiiiiiii s 31

4 Changing.bars to. different.styl@s........ccccoireiiiiiiiiii e 32

5 Changing.text.stylesS by.FOW........c.oiiiiiiii 33

6 INCluding XL DOXES....cuniiieiiiei i 33

T INCIUAING. PICIUIES. ...ceiiieieii it re s e s s e s s s s s s s s s s s s s s s s seasnnsenssnssnssnsnnssnsnnns 34

8 Formatting.pictures and.teXt bOXeS. .....cccoiiiiiieiiiii e 35

9 INCluding.@.1egeNM.... ... e 35

10 Adding.headers.and fOOterS.........oovuuiiiiiiiiiiiii 37

11 Previewing the.custamized schedule..........cccoiiiiiiiiiiii e 39

12 Finishing. TULOrAl 3... ... r e e e s r s s n s e e s e n s en s e s rasnasenassnnsennsnnnns 40
Chapter 7 Tutorial 4: Scheduling Dependencies 40
1 Scheduling Dependencies.-.INtro...........ccoiiiiiiiiiiiii s 40

2 Whatis lInKiNgG 2. ...t r s s e s s s e e e sra e rna e e e e e n e e s e e ranrn e rnnennrnnnns 4

3 Drawing.links.........ccuiiieiiiii e 41

4 Linking.selected bars ... 41

5 Creating.links.in.the.Information FOImM....ccccccooiiimiiiiiiii 42

6 Finishing. TutQrial d............oeniie i e e e e s e e e s na e e em e ennsea i nn e e rnnnnnns 44

Chapter 8 Tutorial 5: Tracking Progress 45
1 Tracking. Pragress.=.INtro.........c.uiiiuiiiieiiii e e ea 45

2 What.is progress.trackiig?.......... oo e e e e n e e 45

3 UsSiNg. ReVised.dates........ccuiieiieiiiiiicii e s cr e e e e e e e rnnnnnn 47

4 Resetting.Revised.dates...........couiiiiiiiii i 48

5 Using.Actual.dates.and.% Complete.........cciiiiiiimiiiiiiiiiin i 49

6 Designing.Scheduled,.Revised,.and.Actual.bar.display............cccooormiiiiiiiiiiieeee, 50

7 Finishing.Tutorial b, i .. oo eecercrrerrereearennren e s EO e e s m i a e 51

Chapter 9 Tutorial 6: Using the Work Calendar 51
1 Using.the.Work.Calendar.-.Intro..........c.cciiiiimiiiiii i e 51

2 Defining.a . WOork.Calendar........ ..o s e rea s re s re s en s en s e s nasnaenasennsnnnss 52

3 Displaying.the Work Calemdar. ... e e e e e s e s s s s em s snnsnansea s rnnsrnnnnnns 54

4 Creating.a.task specific. Work.Calendar..........c...cuuiiiiiiiiiiiiiii e 55

5 Finishing.TULOral.B........coomuiiie e e e e 57

Chapter 10 Tutorial 7: Filtering & Sorting 57
1 Filtering.and.Sorting. = INtro.........coiiii e 57

Copyright © 2010, AEC Software, Inc. All rights reserved.



6 FastTrack Schedule 10 Tutorials Manual

B N o o1 T 4V - T =Y Pt 58
3 Defining.a.filter. ... ... e 58
4 Hiding.aCtiVilies. .....coovuuiiiiiiii i 61
5 Restoring filtered.activities...........cooiiieiiiiiiii 62
LS o o] YT Ve P = o T o PP 62
7 Defining.@a.SOrt ... .o e 63
8 Restoring sorted. activities.........cccoiiieiiiii 65
9 Finishing.Tutorial.Z.........conirmii 65
Chapter 11 Tutorial 8: Using Summaries & Calculations 65
1 Using.Summaries and.Calculations.-.Intro.............cooviieiiiiiiii 65
2 Adding.a.COLUMML SUMMIATY....uuiiiuiiiuirra e e s rea e s s e ra s raas s sraa s rrnasenassenasans 66
3 Defining.a.calculation. COIUMN..... ..o e e e e s e s e e e rnaenas 67
4 Setting.up.a.calculation..........ccovuiiiiiiiiiiicrrr e e rrans 68
5 Defining.a.summary.graph EQW.........c.oiiuuiiiiiii i e 72
6 Finishing.TUtOrial.8........cocouiiiii 74
Chapter 12 Tutorial 9: Working with Resources 74
1 Working.with Resources.-.Intro............cooouiiiiii s 74
2 Creating.@.NEW.LESOMUECE. ... cuuieeuieea e ra e ra i rea e s e s s Emsa s s e e s e e s e ea s ea s rrna s e na s rena e 74
3 Assigning.a.resource. £0.an achVity........coiiiiiiiiiiiiii s 76
4 Viewing resource.assignments.in.the.Schedule VieW...........ccooeoriiiiiiiiiiicice e 78
5 Viewing reSourCe. SUDBIOWS......cciiiuiiiii e s e rrssn s s e s e s s s e sna s n s emasennsnansnann s e e nenns 80
6 Finishing.TUtOrial. ... e 81
Chapter 13 Tutorial 10: Using FastSteps 81
1 Tutorial. 10~ UsSing.FastStePs......c.couiiieiiiiii e e e e e rearra s e e rn e rn s ennennnenannnn 81
2 What.are. FastSteps . ... ..o e e s s e rr e r e e e e e e e narnanrn e ennnean e 81
B T o] YT = T o= K= 653 7= o 81
4 Creating.a.basiC.FastSIep.......cciimii e e e enn e 82
5 Creating.a.basic.FastStep.(Cantd)...........ccooiimiiieiii e e e nas 84
6 Finishing. Tutorial.A0........cc.iiinii e e e e e e e e e naas 86
Chapter 14 Tutorial 11: Consolidating Files 86
1 Tutorial.11.~Consolidating.Files.........cce i e e e e e e 86
2 Understanding .Consolidation...........cccoiiiiiiiiiiiiiii s ers e e re s en s e s s e na e n e e enan s 86
3 Defining.Consolidation.........ccuiiiuiiiiiii e e e 87
4 Finishing.Tutorial. Ad... ..o e 88

Copyright © 2010, AEC Software, Inc. All rights reserved.



Contents 7

Index 90

Copyright © 2010, AEC Software, Inc. All rights reserved.



FastTrack Schedule 10 Tutorials Manual

Tutorials

Tutorials

These tutorials will get you up and running quickly. They are constructed to be used with the FastTrack
Schedule practice Tutorial files (Tutor1 — Tutor11).

To open the FastTrack Schedule practice Tutorial files:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file (for example Tutor1.fts (on Windows) or Tutor1 (on Macintosh))
that accompanies the tutorial instructions with which you are working.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor1.

fts" (Windows) or "Tutor1" (Macintosh). If this produces no results, check with your System
Administrator to make sure the Tutorial folder was included when FastTrack Schedule was installed on
your computer.

If necessary, select one of the following:

Using the tutorials
Printing the tutorials

Table of Contents:

2 Tutorial 1: Up and Running
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Using the Tutorials

Using the Tutorials

Tutorials consist of a set of step-by-step instructions and sample schedule files on which you perform
those instructions. You open the step-by-step instructions online in the application’s Help contents.
Tutorial practice files were installed along with the application, as were the Example files, unless a
custom install was performed and these files were not included in the installation.

To begin a tutorial:

1. Open FastTrack Schedule.

2. From the Help menu, select Tutorials, and choose Tutorial from the submenu.
3. Click the icon beside the name of the tutorial you want to view.

To open the practice schedule file to be used while taking the tutorial:

Copyright © 2010, AEC Software, Inc. All rights reserved.
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1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor1 that accompanies the tutorial instructions with which you
are working.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor1". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

To go through the tutorial:

1. Be sure you hawe both a FastTrack Schedule window (displaying the appropriate practice schedule)
and your browser (displaying the appropriate step-by-step instructions) open at the same time. If your
monitor allows it, position the windows so you can work on the schedule while keeping the step-by-step
instructions in view.

See also:
Printing the tutorials
Tutorial Contents

3 Printing the Tutorials

Printing the Tutorials

If you prefer to follow the instructions from a hard copy print out instead of on your screen, you can print
the contents of the tutorials.

To print a tutorial:
1. Open the FTS10Tutorials.pdf file, which was installed in the same location as the Tutorial practice
files.
2. Print the FTS10Tutorials.pdf file.
=0Or=-
1. Open the Tutorials.
This will launch your computer’'s default browser.
2. Use your browser’s Print functionality to print the active page.
This may mean clicking on the right side of the page to awoid printing the Contents frame.
You will have to print each tutorial one page at a time.

Important:

If you cannot locate the tutorial PDF file on your computer, go to Find and search for "FTS10Tutorials.
pdf." If this produces no results, check with your System Administrator to make sure the Tutorial PDF
file was included when FastTrack Schedule was installed on your computer.

Note:
The FTS10Tutorials.pdf document is also available in the Downloads section of the AEC Software
Homepage: http://www.aecsoftware.com

See also:
Using the Tutorials
Tutorial Contents
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4.1

4.2

Tutorial 1: Up and Running

Up and Running - Intro

Tutorial 1 - Up and Running

This tutorial shows you the basics of scheduling, from creating activities to printing the schedule and its
calendar. When you are done, you will know enough about FastTrack Schedule to begin building your
own schedules.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor1.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor1". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

The FastTrack Schedule environment

The FastTrack Schedule environment

In the Schedule View, the timeline, or timeline graph, is the actual grid of horizontal and vertical lines on
which activity bars sit. In the Resource View, the timeline is the actual grid of horizontal and vertical
lines on which assigned activity bars and resource graphs sit. The timeline can represent any range of
time you determine, in units of hours, days, weeks, months, quarters, and years.

A timescale contains timescale rows that label the dates and times on the timeline graph. The timescale
rows can be formatted to display different divisions of the base timeline units. For instance, a schedule
that is divided into base timeline units of weeks might also have timescale rows that group the timescale
into months and fiscal quarters.

Columns — Columns can be placed to the left and right of the timeline graph. There are columns pre-
defined by FastTrack Schedule or ones that you create yourself.

Rows — Rows contain activities, data, and activity bars. You can move them up and down, hide and
show them, sort them into different arrangements, and use them to outline activities.

Timescale area — Sections of the screen that display the timescale rows. The Schedule and Resource
View can each contain two different timescale areas: one above the timeline and one below it. You can
use options in the Define Layout dialog to have the bottom timescale mirror the top timescale.

Base Timescale Row — The timescale row that displays the base timeline units (the smallest units
set). You cannot change the units of the base timescale row; they always reflect the base timeline units.

Width — The width of the divisions in the base timescale row define the width of columns in the timeline.

Therefore, if the Schedule View timeline is in base units of weeks, changing the width of a column in the
row that displays weeks changes the width of the timeline graph.

Action Columns

Copyright © 2010, AEC Software, Inc. All rights reserved.
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4.3

FastTrack Schedule’s Action Columns simplify working with activities and resources. The Action
Columns can be displayed to the left of the columns in the Schedule and Resource Views. They simplify
operations performed on rows, subrows, and outline levels.

Row Number/Select Row.
Clicking here selects the row for moving, deleting, copying, cutting, formatting, and hiding.

= Page Break.
Clicking here makes the corresponding row the last row on a printed page.

e Information Form.

Clicking here opens the Information form in the Schedule View and the Resource Information form in the
Resource View.

4 Expand/Collapse.

Clicking here collapses and expands outline lewels in the Schedule View and subrows in the Resource
View.

Key Tools

Key Tools
To prepare for the steps in these tutorials, review this summary of the key tools within FastTrack
Schedule. If you are already familiar with FastTrack Schedule’s tools, skip ahead to the Viewing the

schedule section.

The Tools control
FastTrack Schedule’s Toolbox contains six tools:

R Arrow tool
The general-purpose tool that selects, moves, and resizes items in all Views. When you want to
drag an activity bar, row, column or graphic item this is the tool you need to have selected.

=
E=| Bar Tool
Draws activity bars in the timeline graph.
=]
== Bar Link Tool
Links bars to create dependencies.
= Revise Tool
Changes the activity’s Revised start and/or finish dates, times, and durations.
B
= Percent Tool

Defines the percent complete and Actual start, finish, and duration of an activity.

Copyright © 2010, AEC Software, Inc. All rights reserved.
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44

T Text Box Tool
Draws and edits text boxes for use as labels and titles.

Important:

Unless a tool is double-clicked, the default setting for each tool in the Tools control is to revert back to
the Arrow tool after use. When double-clicked, a tool is locked down and can be used multiple times. To
change this tool behavior, from the Editing tab of the Preferences>Application dialog, deselect the
Double-click to Lock Tools option.

The Bar Styles tool
The cells of the Bar Styles list contain the bar styles defined for the schedule.

You can use the Bar Styles tool to design a new bar style, edit an existing bar style, or change the bar
style applied to an activity.

Note:
When you select a different bar style all new bars will be drawn in that style and, if an activity bar is
selected in the timeline graph, it changes that bar to the selected bar style.

The Views tool

There are three Views in FastTrack Schedule: the Schedule View, Calendar View, and Resource View.
The Views tool lets you switch from one View to another, instantly.

W =E(T]

The Timeline Range tool

The Schedule, Resource, and Calendar Views can each show a different span, or range, of dates. The
Timeline Range tool gives you immediate access to the Start and Finish dates of the timeline in the
Schedule and Resource Views, and the calendar in the Calendar View.

The dates you set in the Timeline Range tool affect only the View you are looking at and always
correspond to the Start and Finish dates displayed in the respective Format Schedule, Resource, or
Calendar View dialogs.

| ECEES  EEIETEIR  EERS

Viewing the schedule

Viewing the schedule

As you view the Tutorial 1 practice schedule, note that activities are listed in the Activity Name column
and their scheduled dates are shown in the Start Date and Finish Date columns. The number of duration
units between the start date and end date is shown in the Duration column. In the timeline, these dates
are represented graphically as activity bars positioned according to the timeline. This timeline is labeled
by the timescale rows at the top of the schedule.

Copyright © 2010, AEC Software, Inc. All rights reserved.



Tutorial 1: Up and Running 13
March 2012
_,: @4' Activity Name Duration StartDate | Finish Date |Mon Tues Wed Thur Fri | Bat Sun Mon Tues Wed Thur| Fi | Sat | Sun Men Tues|Wed
12 (13 |14 15 |16 |17 [18 [ 19 |20 | 21 |22 |33 |24 |25 25 |27 |28
4| | | |[Beainstom g0 | a2z 3MAM2 T | L | E ol
| 2 | Research 3.00 N3z 3812 | f———] | |
2 Buaget .00 E T ez || > | |
(& | Desgn 2.00 31912 32012 | | — |
P Frototype a0 32012 sz || | P ———— |
| & | Review 3.00 32612 T | | |

Notice that this schedule displays its timeline graph in units of days. If this schedule were displayed in

units of weeks, there would be one timeline graph column for each week instead of each day.

4.5 Creating activities

Creating activities

To add activities to the schedule, you enter their names in the Activity Name column and then enter their

dates.

Steps:

1. In the Toolbox, be sure the Arrow tool is selected. A
2. Click in the Activity Name cell of the first empty row.
3. Enter the word Preliminary in row 7.

4. Press the Down Arrow on your keyboard to move the insertion point to the next row and enter the

name, Customer.
5. Press the Down Arrow again and enter Final Review.
6. Press the Down Arrow once more so that "9" appears in the Row Number Action Column.

March 2012
_1' @4€ Activity Nama Duration Start Date | Finigh Date |Mon Tues Wed Thur Fri | Sat  Sun Mon Tues!Wed Thur| Fr | Sat | Sun Mon Tues Wed
1213 |14 15 |8 1z |18 | 10 | 20 |2 |22 2o |24 |25 |25 |27 |2
B | [Brainstorm 30| aianz atanz T 1 1 1 | | 1 [ ]
| 2 | Research 3.00 3Nz 31812 | | ——— ]
2 Budget 0.00 iBMZ wienz || >
[ & | Design 200 3oz 32012 | S———
g Frointype 400 202 szanz || e —
& |Review 3.00 26M2 w282 |
7 Preliminary [
| 8 | Customer |
9 Final Review [
46 Drawing bars

Drawing bars
Because the position of an activity bar in the timeline graph represents an activity's start, finish, and

duration dates, you can draw a bar to automatically enter those dates in the columns.

As you mowe the cursor in the timeline graph, you can see the date and time over which it is positioned
in the Cursor Tracking area at the bottom right of the application window. In addition, while you draw the

bar, the Bar Tracking window pops-up, and shows the current bar’s start, finish, and/or duration.

Copyright © 2010, AEC Software, Inc. All rights reserved.
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4.7

Steps:
i
1. From the Tools control, select the Bar tool. ==

2. From the Bar Styles tool, click this bar style .
3. In the Preliminary row, click in the timeline graph on day 29 and, holding down the mouse button, drag
to the right until the bar’s duration is 2 days.

March 2012
dﬁ @ ‘- Activity Name Duration Start Data Finigh Date | Mon Tues Wed Thur Fr | Sat  Sun Mon Tues Wed Thur| Fri | Sat  Sun Mon Tues Wed Thur| Fr
12| 13| 14| 15 | 16| 17| 18 |19 | 20| P71 | 2P | 23 | 24 | 285 | 26| 27| 2B | 25 | 30

| 1 . Brainatorm 3.00 a2z 31812 [ ———— '
[z |Research 3.00 ANz 812
3 Budget 0.00 1612 31612 -
| 4 | Design 200 Az 22012 ——
P Frototype 4.00 w20z J2anz
g | Review 3.00 2812 28M2
T Frefiminary 2.00 2012 330Mz [ —
8 Customer
9 Final Review

Typing dates

Typing dates

You can also define activity dates by typing values in the Duration column or the Start Date and Finish
Date columns. You only have to enter a Start Date and Finish Date, a Start Date and Duration, a Finish
Date and Duration, or simply a Duration-FastTrack Schedule automatically calculates the remaining
value and draws the bar.

Steps:
1. Click in the Start Date cell of row 8, the Customer row.
2. Enter a Start Date of April 02, 2012 in the Express Date calendar and click OK to enter the date in
the cell.
3. Click in the Duration cell.
A Duration of 1.00 is entered by default, select the data in the cell.
4. In the Duration cell, type 2 and press the Enter/Return key on your keyboard to enter the value.

March 2012
J,' 64‘ Activity Nams Duration Start Date Finish Date |Mon Tues Wed Thur| Fri | Sat | Sun | Mon Tues Wed Thur| Fri | Sat | Sun |Mon Tues/Wed Thur| Fri | Sat  Sun  Mon Tues
12- 119 |4 (15 |16 (9% | 18 | 18 |20 |29 |28 |23 (24 |25 (26 |RY | 2B |28 |30 |3 1 2 3

- | |Brainstom 300 | a2z Wanz | 1 T [ T T | 17 T T T | R
|2 | Research 200 3anz 31612 | ———
3 Budget 0.00 612 3MEM2E | s
| . | Desgn 200 RGN 2012 | ———
s Froiotype a0 32012 vz ||
W [Raview 300 ez | meEn |
7 Preiminary 200 a2 ETRTT I e
g | Cusiomer 200 4Rz a2 | .
9 Final Review | |
Note:

Because the bar style was still selected in the Bar Style list, it is that bar style that is drawn
when you enter the dates.

Copyright © 2010, AEC Software, Inc. All rights reserved.
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4.8

4.9

Drawing milestones

Drawing milestones

So far you have worked with activities that have a start and a finish. What about activities that do not
really have duration-that are just a moment in time, such as a deadline? These types of activities are
represented by another style of graphic called a milestone.

Steps:

1. From the Bar Styles tool, click the single green diamond-shaped bar style N4 .
2. In the Final Review row, enter 04/04/12 in the Start Date column and press the Enter/Return key on
your keyboard.

A milestone appears on that date in the timeline.

March 2012
= AT actiiy Name Durabon | StartDaste | Finish Date |Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed
12|13 |14 |15 | 16|17 |18 |18 |20 |21 |22 |23 (24 |25 |26 |27 |28 |20 |30 M |1 |2 |3 |4

B | i T gz |1 L ]| ol B Bl B el el it B B B B Jeegsl
| 2 |Research 3.00 3nanz 62 | e
3 Budgel o.00 EUT ez || -
| 4 | Design 200 2Nz 32012 | e———
5 Prototype a0 320012 sz ||
| & |Review 200 22612 2812 | ———
7 Preliminary 200 2012 330z | R
| s | Customer 200 A2z A3z |
9 Final Review 0.00 A4z A4z | &

Dragging bars

Dragging bars

Dragging bars is one way of changing an activity's dates. By using the Arrow tool to drag the middle,
start, or end of a bar, you can change the activity's start, finish, or duration. If they are displayed, these
changes will appear in the time, date, and duration columns.

Steps:

1. To drag a bar, select the Arrow tool from the Tools control.

2. Click the middle of the Brainstorm bar and drag it to the right two days.
The start and finish dates change, but the duration remains the same.

3. To change the finish of a bar, click the end point of the Research bar and drag it to the right two days.
The finish date and duration change, but the start date remains the same.

March 2012
= AT actiiy Name Durabon | StartDste | Finish Date |Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed
12 |13 |14 |15 | 16|17 |18 |18 |20 |21 |22 |23 |24 |25 |26 |27 |28 |20 |30 |® |1 |2 |3 |4

B | i . ———T L | | ol B Bl B el el it B B B B Jeegsl
"z |Freszarch 5.00 313z ez | I
3 Budgel o.00 1Bz ez || - |
| 4 | Design 200 2Nz 32012 | | e———
s Prototype a0 2012 sz || |
| & |Review 200 22612 2812 | | ———
7 Preliminary 200 2012 330z | | R
g | Customer 200 Ajzhz 473Nz | | A
9 Final Review 0.00 A4z A4z | | -

To change the start and finish, drag the middle of the bar. To change the start and duration, drag the
start point of the bar. To change the finish and duration, drag the end point of the bar.
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410

411

Changing the schedule date range

Changing the schedule date range

Now that you know how to enter and change activity dates, you will also want to view different periods of
time in the timeline graph. Currently the timeline graph shows you a time range from April 14, 2012 to
June 19, 2012 with each column representing one day.

These steps illustrate how to change the schedule's start and finish dates to view a different range of
time.

Steps:

1. From the Timeline Range tool, click in the start date box to select the current value and enter
03/01/2012 in its place.

2. Click in the finish date box to select the current value and enter 04/30/2012 in its place.

3. Press the Enter/Return key to apply the new range.

You can also change the schedule range using the Format Schedule View dialog. You open this dialog
from the Format menu by choosing View, while in the Schedule View. The Format Schedule View dialog
lets you change every aspect of a schedule including its: date range, base timeline units, duration units,
timeline display, column, timescale, work calendar, and gridline display.

Typing to change dates

Typing to change dates

Instead of drawing and then dragging activity bars, you can also change an activity's dates and duration
by entering new values in its Start Date, Finish Date, or Duration columns. This works for activity bars or
milestones.

Steps:
1. In the Final Review row, select the value in the Start Date cell and enter 04/06/12.
2. Press the Enter/Return key.

The milestone mowes to the new date.

March 2012

Jﬁ @4 Activity Mame Duration Start Date Finigh Date |n Tues Wed | Thur Fri | Sat Sun Mon Tues Wed Thur Fri | Sat Sun Mon Tues Wed Thur| Fri | Sat Sun | Mon Tues/Wed Thur Fri
13 |14 |48 [ 48 |17 |18 | 18 |20 |21 |22 |23 |24 |25 |28 |'2¢ |26 |20 (30|23t |4 |2 |38 |4 |8 |68

1 | Brainstorm 00 nanz ez |

2 | Ressarch 500 Falz gz —————

2 | Budget 0.00 612 3162 - |

P | Design Z.00 ez 320112 | —

5 | Prototype 4.00 EITF azanz |

8 | Review 200 326112 32812 | E————

7 | Preliminary 200 220012 230N2 | —

8 | Customer Z00 A2z Az | A

? | Final Review 0.00 4612 4612 | >
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412 Printing the schedule
Printing the schedule
When you are ready to print your schedule, Print Preview illustrates exactly how the schedule will
appear when printed.

Steps:

1. Click the Print Preview button EEEEEETEEIERE

If you are connected to a printer, the Print Preview window opens. Print Preview contains an image of the
printed page. To the left of the window, there are areas for selecting the different pages of a schedule,
tools for working with text boxes and pictures, and dynamic stamps you can add to track page numbers,
current dates and times, and file names.

2. From the File menu, select Print.
3. Follow your normal printing procedures.

413 Printing the schedule in Calendar View

Printing the schedule in the Calendar View
As you have been setting up your schedule, a calendar containing your activities was being created at
the same time. You can open the Calendar View by selecting Calendar from the View menu or clicking
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the Calendar button on the Views control.

You can use the same steps for changing the schedule range to change the date range shown in your
calendar.

When you are ready to print your calendar, Print Preview shows you exactly how the calendar will look
before you print.

Steps:
1. From the View menu, select Calendar.
The Calendar View opens.

walaliC—— 8 -l coei8 sl

March 2012 m
Sunday Monday Tuesday Wednesday Thursday Friday Saturday |
11 March 12 13 14 15 16 17 :
BT |
S — |
18 19 20 21 22 23 24
w ——————————————— U eee——————————————
—— Y —
25 26 27 28 29 30 a1
— . G .. M
April 1 Z 3 4 5 3 7
S — o L
ry
v

2. From the File menu, select Print Preview.
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414

Vareh 2012
Suntsy | Mondsy  Tuesisy  Wecresduy| Thursday iy | Salurday
11 Mirch 12 13 14 15 16 7
—
—_—
- hn
-
18 19 - 2 2 n 24
— e —
BN
@ o6 o4 28 2% 30 £l
[T
A ] ) 7 5 G o
A * =
=
8 E] 10 1t 12 18 "

3. From the File menu, select Print.
4. Follow your normal printing procedures.

Finishing Tutorial 1

Finishing Tutorial 1
You are done with Tutorial 1. You now know the very basics of FastTrack Schedule. The next two
tutorials build on these basics, showing you how to layout and customize your schedule.

To close the Tutor1 file:
1. From the View menu, select Schedule.
The Schedule View opens.
2. To close the Tutor1 file, from the File menu, select Close.
3. Click No to close the schedule without saving your changes.

To start the next tutorial:

1. Go on to Tutorial 2: Laying Out Your Schedule.
=0r-
Return to the Tutorial Contents.
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5.1

5.2

Tutorial 2: Laying Out Your Schedule

Laying Out Your Schedule - Intro

Tutorial 2 - Laying Out Your Schedule

This tutorial shows you how to change the general layout of your schedule by outlining activities and
working with columns, layouts, and timescales.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor2.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor2". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Indenting outline levels

Indenting outline levels
You create outline lewvels by indenting activity names. Indenting an activity makes it a subactivity of the
level abowe it.

March 2012 Agpril 2012
= AT actiiy Name Durabon | StartDaste | Finish Date |Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed
12|13 |14 |15 | 16|17 |18 |18 |20 |21 |22 |23 |24 |25 |26 |27 |28 |20 |30 M |1 |2 |3 |4
1 | |Pranning 400 | 322 316M2 I | | | | | I | | | | | I | |
2 Brainstorm 200 32z 3ianz '—'—-r
3 Ressarch 300 aanz L ————
. Budget 0.0 38z 362 | &>
s w | Deveicpment 8.00 a2 a2 | |
& | Design 200 a1z 2012 | e
7 Frofotype a0 a20Mz sz ||
F | Faview 300 IENZ T | pr————
9 Testing |
| 10 | Prefiminary 200 22012 3A0MZ | o
|44 Customer 200 Az 473z I A
| 12 | Final Review 0.00 A4z Aanz | -
Steps:

1. In the Preliminary activity’s Activity Name cell, click before the word Preliminary to place the blinking
insertion point there.

2. Press the Tab key on your keyboard to indent the name.

3. Indent the Customer and Final Review rows using the same method.
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5.3

March 2012 Apri
=il By Activity Name Duration Start Date | FinishDate \M|T W T F|S S M|T W T FI5|5 MTWTFSS5MTW
12113 14 1516 17 18/19/20 21 22 23 24 25 26 27 2§ 28/3031 1 |2 3 4
1 w Planning 4.00 31212 IMEM2 |
2 Brainstorm 3.00 3na2n2 31412 |:I
3 Research 3.00 3nanz2 ansnz [
4 Budget 0.00 3nen2 3nenz &
5 w Development 8.00 3nanz 32812 - S———
6 Design 2.00 3nanz2 3202
T Frototype 4.00 32012 323Nz
8 Review 3.00 3/26M2 328Nz
9 v Testing 5.00 3128112 4/a112 S
10 Preliminary 2.00 312812 3poA2 || —
11 Customer 2.00 33012 41312 ' A———
12 Final Review 0.00 4/412 414112 <

Outlining activities helps organize the schedule and provides a way to simplify the schedule by
collapsing and expanding outline levels. You can also indent activities by clicking the Indent button in
the Outline Toolbar or choosing Indent from the Outlining submenu of the Schedule menu.

Collapsing outline levels

Collapsing outline levels

When activities are outlined, you can collapse each outline level to hide its subactivities. When an
outline lewel is collapsed, the Expand/Collapse triangle points to the right and the activity name is
followed by an ellipsis. This ellipsis is especially helpful for identifying collapsed outline levels when the
Expand/Collapse action column is not displayed.

Collapsed outline levels can also display summary bars-activity bars that extend from the beginning of
the first collapsed subactivity to the end of the latest collapsed subactivity.

To collapse an outline level:
1. In the activity named Development, click the triangular handle in the Expand/Collapse action
column.

March 2012 Agpril 2012
= AT actiiy Name Durabon | StartDaste | Finish Date |Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed
12|13 |14 |15 | 16|17 |18 |18 |20 |21 |22 |23 |24 |25 |26 |27 |28 |20 |30 M |1 |2 |3 |4
3 v |Panning 4.00 Iz wienz ||
2 Brainstorm 200 32z 32 |
3 Ressarch 300 aanz L ————
P Budget o.00 ez 38z | &>
s p |Development... 8.00 a2 vzz | |
9 v | Testing 4.00 3232 4ai2 |
| 10 Prelminary 200 2912 A2 | R
|44 | Customer 200 Ajzhz 473Nz | A
12 Final Review 0.00 A4z A4z | -

The subactivities of Development are now rolled-up. Note the summary bar in the Development row.
Summary bars display by default. Summary bar options are available in the Summary Bar tab of the
Format Row dialog. You can choose not to display summary bars and choose the style in which you
would like summary bars to display.
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54

5.5

Expanding outline levels

Expanding outline levels

The Expand/Collapse action column acts like a toggle switch, so when outline levels are expanded, the
triangle handle moves to point downward. Here, you will employ another method to expand the activity
so that you will know how to expand and collapse your activities even if you choose not to display that
Action Column.

To expand an outline level:
1. From the Project menu, select Outlining, and choose Expand All.
This displays all subactivities in your schedule.

March 2012 April 2012
4'1 @4 Activity Name Duration Start Date Finigh Date Mon Tues Wed Thur| Fri | Sat | Sun |Mon Tues Wed Thur| Fri | Sat | Sun | Mon Tues/Wed Thur| Fri | Sat | Sun |Mon Tues Wed
12 [ 93 |94 |48 [ 48 |97 |98 |90 |20 |24 |25 |23 |24 [25 |26 |27 | 2@ |28 (a0 a1 |4 |2 | & |4
3 S [Paing R JdEl g Rl e el S s S ) JiEel S
————————
2 | Brainstorm | zoo a2 | ANZ |
3 | Research 300 Hianz 36Nz e
4 Budget 0.00 1612 ETI >
5 | Devalopment 8.00 ez 22
& | Design 200 Iz | 32042 —
7 | Prototype 4.00 220012 22312 ——
8 | Review a0 L2ENZ | RzAnz ——
8 w | Tesiing 4.00 29i12 i1z
10 | Preiminary Tz J29MZ | AE0AZ e
1" | Customer 200 Aj21z aanz
12 | Final Review | ooo 4412 | 4Nz *

Viewing a different layout

Viewing a different layout

The layout of a schedule is a "view" of its information. The layout determines which columns are
displayed and in what order. Layouts also determine which, if any, Action Columns, summary graphs,
and timescale areas are displayed. You can select a application-defined layout or create your own.

Steps:
1. From the Project menu, select Layouts, and choose Basic Layout from the list of pre-defined
layouts.

"Activity Name" is now the only column displaying to the left of the timeline.
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March 2012
_T',‘ @ f Activity Narme Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat  Sun Mon Tues Wed Thur Fr | Sat  Sun Mon Tues! Wed
12 13 | 44 |15 |18 |17 |18 |18 (20 |24 |22 (23 |24 |25 |26 (27 |28 |28 [30 [ | 4 2 3 | 4

| v | Planning
| Beainstorm e
| Research |
Badget -

4 | Development

Design [—

Prototype e ——————

| Rewvew

TR N S ST

L 4 | Testing

Preliminary F o ——

| Custormner

|

| Final Rewew

-
]

5.6 Inserting columns

Inserting columns
You can insert columns using the Insert Column dialog. All columns are hidden until you choose to
show them. Here you will insert a column that is currently hidden.

Steps:
1. Select the column heading of the Activity Name column.
2. From the Insert menu, select Column.
The Insert Column dialog opens.
3. From the Show pop-up list, select Text.
. Click to highlight the first item in the Column Display Name table.
4. Type "t" to cause the list to scroll to and select the item Text 1.

SN
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Show: [ Text hé‘

Column Display Name |
Attendees
Location
Notes
Text 1
Text 2
Text 3
Text 4
Text 5
Text 6
Text 7
Text 8
Text 3
Text 10
Text 11
Text 12
Text 13
Text 14
Text 15
Text 16
Text 17 v

® ( Cancel )6—8&—*

5. Click OK to insert the Text 1 column and close the Insert Column dialog.

Activity Name Text! |Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat Sun|Mon Tues/Wed
i W12 13 14 15 18 17 18 18 20 21 22 23 24 25 26 27 28 28 30 M 1 2 | 3 4

Bramstorm : | | | |

I March 2012
|
|

i

|

|

| Devesopmant [
|

|

|

Design ——
Pratotype eee——

Rensigw

LT T - T S S

v | Testing

Prefiminary | | | | I [ | | | | | I | | A

| 44 Customer -

|
e - e R R RN P S R PR I P S | PO R PR ! ”

Formatting columns

Formatting columns
The format of a column determines what type of information it contains and how that information is
displayed. Here you will create a new column called "Manager."

Steps:
1. Ifit is not already selected, select the Text 1 column.
2. From the Format menu select Column.
The Format Column dialog opens in the Options tab.
3. In the Customized Column Name box, enter Manager.
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Il ‘Options = Default Values  Value List Display Font  Summaries 1

Customized Column Name:

{Manager ] Use Default

Default Column Name:

Text 1

Column Type Specific Options

[ Stored per bar

E Show in Information Form

Define Calculation...

® ( Cancel )f—ﬂl(——a

4. Click the Display tab.

5. Enter 85 in the Column Width box.

6. Click OK to close the Format Column dialog.

7. Incells 1, 5, and 9 of the Manager column, enter the manager names listed in the graphic below.

March 2012

. A [
?ﬁ @ ff‘ Activity Name Manager Mon Tues 'Wed Thur! Fri | Sat | Sun Mon Tuas Wed Thur Fr | Sat | Sun  Mon Tues Wed Thur Fri | Sat | Sun | Mon Tues Wed
12. |43 [ A4 |45 [ 46 | A7 |48 | A8 |20 | Bt | 2P |23 |24 [ 25 | 28 | 2Y [ 26 |28 | A0 [A1 | 4 r| [ ] [

R T R N S

|
e s
v | Pranming Smitn
| | Beainstorm | : | | | |

| Ressarch | E——|

Sudiget ] | | | .“ ]
| Davelopment Hing I | | I

Design —
Prototype
Rewiew

| v :Tasijng Wiliams

T Frefiminary | | | | | | | | | | T T I T T o

| Customer

Final Rewiew

5.8 Designing a new layout
Designing a new layout
The Layouts dialog not only lets you apply layouts to a schedule, it also lets you design your own. Here,
you will create a new layout.

Steps:
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1. From the Project menu, select Layouts, and choose Define from the submenu.
The Layouts dialog opens.
2. Click New to create a new layout.
The Define Layout dialog opens.
3. Enter My New Layout in the Layout Name box.
4. To add a column to the layout, select Duration in the Available Columns table, and click the Show
button.
The Duration column appears in the Shown Columns table.
5. Using the same method, send the Manager, Finish Date, Start Date, Activity Name, and
Timeline Graph columns to the Shown Columns table.

Keep the Define Layout dialog open for the next section.

Define Layout

[Coiumns Summary Graphs 1

Layout Name: My Layout

Headings, Summaries, and Timescales Shown

g Column Headings and Timescale (Top)
E Column Summaries and Timescale (Bottom)

[ Mirror Timescale from Top

Columns Shown

Available Columns Shown Columns Lock

% Complete m Activity Name =]
% Used Start Date H
Activity Row ID { show ) |Finish Date 0
Activity Row Number [’T\ Manager H
Actual Duration " |Duration B
Actual Finish Date Timeline Graph
Actual Finish Time ( Hideall )
Actual Start Date FE——
Actual Start Time 3
Attendees v

m ( Cancel W f 0K )

5.9 Designing a new layout (cont'd)

Designing a new layout (cont'd)

Steps:
1. In the Shown Columns table, drag Duration below the Timeline Graph.
2. Click the box to Lock the Duration column to keep it on screen.
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{ Columns

Summary Graphs 1

Layout Name: My Layout

Headings, Summaries, and Timescales Shown

E Column Headings and Timescale (Top)

E Column Summaries and Timescale (Bottom)

71 Mirror Timescale from Top

Columns Shown

Available Columns
% Complete
% Used
Activity Row ID
Activity Row Number
Actual Duration
Actual Finish Date
Actual Finish Time
Actual Start Date
Actual Start Time
Attendees

@

Hide All

Shown Columns | Lock
Activity Name . B
Start Date =]
Finish Date B
Manager B

Timeline Graph
Duration

£l

( Cancel jf—*—ﬂlﬁ—*’

2. Click OK to close the Define Layout dialog.
3. Click OK to close the Layouts dialog and view your new layout.
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P T [ [ Paaring s
2 | Brainstorm iz
I3 | Research EGET
& | Budget 316z
s w | Deveicpment a2
| & | Design 01E
[ 7 | Prototype 20012
P | Review ELTH
o w | Testing 302012
| 10 | Preliminary 201Z
: 1 I | Custamer Az
2 | Final Review iz

Finish Date

ez

| aAanz

3nsn2
3enz
JHzaMz

| a0z

323anz
281z
442

| amonz

43z
AJaNZ

Manager

Smith

Willams

March 2012 April 2012
Mon Tues Wed Thur Fri  Sat Sun Mon Tues Wed Thur Fri | Sat Sun Mon Tues Wed Thur Fri | Sat Sun Mon Tues We
12|18 [t |15 |18 | 17|18 |18 | 20 |21 |22 |23 |24 |25 |2 |27 |28 |20 |30 |3 1 2 3 4
-
—

5.10 Inserting and formatting timescale rows

Inserting and formatting timescale rows
Here you will add a timescale row to the top timescale area and format it to show quarters.

Steps:

1. In the top timescale area, click in the top timescale row to select it.
2. From the Insert menu, select Timescale.
The Format Timescale Row dialog opens.
3. Select Quarters from the Units pop-up list.
4. Select the First Quarter option.
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!-Disp!ay | Gridlines |

Units: f Quarters I'-H

Quarters

Display:

Qa1

) 1stq

() First Q

(O Quarter 1
O 1st Quarter
® First Quarter
)

® (" cancel ) k)

5. Click OK to apply your changes and close the Format Timescale Row dialog.

March 2012 April 2012
= | First Guarley Second Quart

S OAY actviy Neme StartDate | Finish Data Menager Sl eoond SMARET | Duration

E = Mon Tues Wed Thur Fi  Sat Sun Mon Tues Wed Thur Fi | Sat Sun Mon Tues Wed Thur Fri | Sat Sun Men Tues We

12 |13 |94 |15 | 96 |47 | 18 | 19 |20 |2 |22 |28 |24 |28 |96 |27 |28 28 e & | 1|2 |3 | @
3 e R R G 2 il o] o8 B B2 ] Bl e S S i v T Iy S

| [ ——

2 | Beainstorm 2z | ananz F—— 1 [ 1 1 [ 1 1 2.00
3 | Researcn a3z 31812 [——] | 3.00
7 Budget ez ECTEH &> 0.00
5  |Deveicpment B8z 2812 King | 8.00
8 | Design 3M9ME | 20012 I I I I I | — I I I I I I il 200
7 | Prototype wIE 2312 pr————— | 400
8 Review 2612 w262 — 3.00
2  |Testing 329012 44z Willems ! 4.00
10 I | Frebminary 3EOMZE | 3302 | I Il 200
1 | Customer a2z 4z = = 200
12 I | Final Review ANz | ARz T 1 T 1 | 1 1 1 1 e 0.00

5.11 Moving timescale rows

Moving timescale rows
After inserting a timescale row, you can move it anywhere in the timescale area.

Steps:

1. Click the Month timescale row to select it.

2. When the mowe cursor appears, drag the outline of the Month timescale row all the way under the
Quarters timescale row.
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First Qusrtar Seconc Quarter
S @AY sctviy Neme StartDate | Finish Date Mznager Match S apoketis Duration
E < Mon Tues Wed Thur| Fi  Sat Sun Mon Tues Wed Thur Fi | Sat Sun Mon Tues Wed Thur Fri | Sat Sun Mon Tues We
12|13 |94 |15 |96 a7 |18 |19 |20 |2 |22 |28 |24 |28 |26 |oF |26 20 [ao w1 2|3 @
1  |Planning a2z 316M2 Smith 1 4.00
——
2 | Brainstorm aznz a1z — 20
3 | Ressarch 23z 316012 [—— 300
7 Budget gz ECTEH &> 0.00
5  |Deveicpment a2 812 King | 8.00
8 | Design ERETE 32012 —— | 200
7 | Prototype 32012 EER e ———— | 4.00
8 | Revew 326M2 2612 —— | 3.00
9 v | Testing 29z A4z ‘Wiliams ! 4.00
10 | Prelminary 32012 3012 — 2.00
11 | Custorer A2z amnz A 2.00
12 | Final Review Az Az > 0.00

5.12 Resizing the timeline-columns

Resizing the timeline-columns

As a final modification to this schedule, change the width of the timeline-columns. The width of the
timeline-columns is determined by the width of the divisions in the base timescale row - the row that
defines the smallest unit of time displayed in the schedule.

Steps:
1. To resize the timeline-columns, be sure the Arrow tool is selected and position the cursor over a
vertical gridline dividing units in the Weeks timescale row.
2. With the Horizontal Resize cursor, click and drag the gridline a little to the right.
The width of all of the gridlines change at the same time.

First Cuarler

| March 2012

S @41 actviyNeme StartDate | Finish Date Manager it Duration

- s Mon |Tues Wed Thur Fr | Sat | Sun  Mon Tues  Wed Thur Fn | Sat | Sun | Mon Tues \Wed  Thur

2| % | 2% |15 [ s | ar | e | 9 |20 |21 | 22 |23 | 24 |25 | 26 | or | zm |20
1  |Planning 2z 31612 Emitn ! 4.00
| s s e o e s

2 Beanstorm 2z ERETEH] [——] 200
3 | Rassarch Az WIEMZ 300
e Budget 3812 3812 > 0.00
5 | Development 38z 328112 King 8.00
8 | Design ananz 20012 — Z00
7 Protatype 220012 w2a2 EEe———— 4.00
8 | Revew 32612 32812 EEe— 300
s w |Testing 2112 iz | Wiliems 4.00
10 Preliminary 220112 302 1 200
1 | Customer A2z a3z 2.00
12 | Final Revew ARz ANz 0.00

5.13 Finishing Tutorial 2

Finishing Tutorial 2
You are done with Tutorial 2. You now know the basics of laying out your schedule through outlining, columns,
layouts, and timescales.

To close the Tutor2 file:
1. To close the Tutor2 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:
1. Go to Tutorial 3: Customizing Your Schedule.
-or-
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6.1

6.2

Return to the Tutorial Contents.

Tutorial 3: Customizing Your Schedule

Customizing Your Schedule - Intro

Tutorial 3 - Customizing Your Schedule

This tutorial shows you how to customize the appearance of your schedule by inserting or modifying bar
styles, text boxes, pictures, and other items.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor3.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor3". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Formatting bar styles

Formatting bar styles

FastTrack Schedule does not attach any meaning to the appearance of a bar style. This leaves you free
to design your own bar styles to fit personal tastes or standards put forth by your organization. Bar
styles are stored in the Bar Styles Toolbar as a library of bar styles, which you can change with the
Format Bar Style dialog.

Steps:
1. Click the Bar Style control and choose Define from the drop-down list.
The Format Bar Style dialog opens.
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Format Bar Sgl_es.
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6.3 Designing the bar elements

Designing the bar elements

An activity bar has three components: Scheduled, Revised, and Actual. Each component displays a
different type of information. In the simplest case, you are just interested in the Scheduled component
since this is the basic bar.

To format a bar, you select which of the three components you will design, how to display that
component, and the appearance of each element (bar, start point, or end point).

In these steps, you will use the Format Bar Style dialog to select the elements of the Scheduled
component and to design their appearance.

Steps:

1. From the Bar Style list, select this bar style E .3

2. From the Type drop-down list, select Bar.

3. To design the scheduled, basic component, select Scheduled from the Component drop-down list.
4. In the Parts tab, from the Part to Edit drop-down list, select Schedule Start Point.

5. In the Shape area, select the diamond point style from the drop-down list.

6. Click the New button to add the now altered bar to the Bar Styles library.

7. In the Point area, enter 9 in the Size box.

8. From the Part to Edit drop-down list, select Schedule Bar.
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9. In the Bar area, select a new pattern.
10. From the Part to Edit drop-down list, select Schedule End Point.
11. In the Shape area, select the diamond point style from the drop-down list.
12. In the Point area, enter 9 in the Size box.
Bar Style | Type:
Bar = o=
* i
Component:
[Scheduled 14
. Compenent Options
o 1
[———]
R { Parts: | Schedule View Labels  Resource View Labels  Alignment ]
| | Part to Edit: | Schedule End Po... '] [ Show All Components While Editing
i =] Shape
: sciect. (& 18]
; Fill Border
v Culor:@ Color: :l
Pattern: '_B‘.
¢ e ) Size: o] [ Size: 1.25| £
Paste = =
— Dffsets
[ Mew :I Wertical: ol [£] Horizontal: 1] [
[ Delete :l
@ ( Apply :] I: Cancel ) E—-OK-—}
13. Click OK to create the bar style and close the Format Bar Style dialog.
6.4 Changing bars to different styles

Changing bars to different styles
In this section, you will change some existing bars in the schedule to the new style.

Steps:
1. In the schedule, select the activity bars in rows 2 and 3 by holding down the Shift key and clicking
each one.
2. In the Bars Styles list, click the cell containing the bar style you just created.
The selected bars adopt the new bar style.
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6.5

6.6

=90 [ Actvity Mame

 |Planning
Branstorm
Research
Budget

v Development
Desgn
Praiotype
Review

w Tesing

prs Prefiminary

1 Customer

12 Final Review

Start Date

a2nz
ananz
AN
38T
382
onz
02
2612
T
ETT
A2AE
ANz

Finizn Date

a6z
¥z
B2
nenz
2812
320012
3232
ez
ETTH]
3012
4z
iz

Mon  Tues Wed | Thur Fn
12 13 14 15 16
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E *
I

|

|

|

|

|

|

|

|

Changing text styles by row

Changing text styles by row

Another way to customize your schedule is to use different fonts, sizes, and styles of text.

Steps:

First Quarter

March 2012
Sat  Sun | Mon Tues Wed Thur Fn
17 & 1. 20 a2 23

Sat  Sun  Mon Tues Wed Thur Fn

24 26 26 27 28 29 30

Sen

A
Sal | Sun | Mon |Tues Wed
170 o | A |

1. Hold down the Command + Shift key and click in the three Activity Name cells of the activities in
outline level 1, Rows 1, 5 and 9.
These are the Planning, Development, and Testing Activities.

2. In the Font controls, in the Size box, enter 12.

3. Click the «B. button to bold the text.

LY

Activity Name

w Planning
Brainstorm

Research

Budget

1

2

3

4

P w Development
P Design

7 Prototype
8 Review

]

w Testing
10 Preiiminary

" Customer

12 Final Review

Start Date

321z
2Nz
aanz
36MZ

311912
39NZ
320012
326012

3129112
33012
ahz

Az

Finish Date

3612
anz
sz
612

328112
32012
23z
328z
a1z
3012
4312

ETTEE)

Including text boxes

Including text boxes

Mon  Tues Wed Thur Fr
12 13 14 15 16

T *
N .
|

|

|

|

|

|

|

|

|

First Quarter

March 2012
Sat  Sun | Mon Tues Wed Thur Fn
17 18 19 20 2 2z 23

Sat  Sun  Mon Tues Wed Thur Fri

24 25 26 ar 28 2% 30

Seo

A
Sal | Sun | Mon | Tues | Wed
O i e

Adding text boxes allows you to label and customize the timeline graph of a schedule. You can add a
box of text to the timeline graph and then format that box with any font styles.

Steps:

1. To add a text box, click the T button to select the Text Box tool from the Tools control.
2. Click in an empty area of the timeline graph and drag out a box of the desired width.
3. Enter the text: These deadlines are essential for meeting our goals.

4. To resize the text box, select the Arrow tool from the Tools control, click the text box, and then drag
one of its corner handles.
5. To change the font attributes of the text box, select the text box with the Arrow tool.
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6. With the text box still selected, click the Format Selected button
The Format ltem dialog opens.

7. Click the Font tab.

8. Click the Italicize button to italicize the text.
You can also use the Font tools to make your changes.

9. Click the button that horizontally centers the text.

10. Click OK to apply your changes and close the Format ltem dialog.

First Quarter Sec
= 4 March 2012 A
=L Aathity Name Duraion  StartDale | Finish Dats e = .

Mon  Tues Wed Thur Fn Sat  Sun | Mon Tues Wed Thur Fn Sat  Sun  Mon Tues Wed Thur Fn Sat | Sun  Mon | Tues Wed
12 13 14 15 18 17 18 19 20 21 22 23 24 25 26 2r 28 29 30 3 1 2 3 4

1 v Planning 400  3M2M2 | 3M6M2 | L

Brainstorm Z00 EUFIFS 132 * Hrmernkia ke pptremet

2 to meating our goals.

3 Research 300 3z viwz ||| *

a Budget 0.00 36Nz ez | &

5 w Development B.00 IMeMz | 3z8nz | |

' Design 200 angnz 20M2 |

7 Prototype 400 22012 vz ||

y Raview 300 EL Tl TETE |

g w Testing 4.00 32912 a4z ||

10 Preiminary 200 20z iz | —

PP Gustomer Z0 iz Wz ||

12 Final Rewiew 0.00 A&z Az | -

6.7 Including pictures

Including pictures
In addition to text boxes you can also add pictures. Pictures are graphic items such as clip art that are
imported into the timeline graph area or Print Preview window.

Steps:
1. From the Insert menu, select Picture.
2. Select Clipboard to include pictures pasted to the Clipboard or File to include a file saved on a disk.
You can either enter the file name and path or click the Browse button to navigate to the file.
Sample picture files are installed in the FastTrack Schedule folder in the Applications folder.
. Click OK.
4. To resize the picture, drag one of the eight resize handles.
You can hold down the Shift key and drag a corner handle to maintain its proportions.
5. You can drag a picture (or text box) anywhere on screen by selecting the Arrow tool and clicking and
dragging the item.

w

First Guarter se0
S @47 achiyName Duraion | StartDate | Finish Date ach L : A
Mon |Tues Wed | Thur Fn | Sat  Sun | Mon |Tues Wes |Thur Fn | Sst | Sun | Mon Tues Wed | Thur  Fn | Sat | Sun  Mon | Tues Wed
) 42|18 [ 2 |45 |76 | a7 | 8 | 19 |20 |21 | 2» |23 | o4 | o5 | o5 | er (‘o8 |28 [@0 (31 [ 4 | 2. (3 | 4
1 w Planning 4.00 3Mznz | aenz2 |
7 Brainstorm 200 a2z EUET T * ”‘5"‘?‘; i?:::;:z:fg;:?:”’“’
S Ressarch 300 iz | wEE ||| *
7 Budget 800 EnT | aEnz | >
5 w Development 8.00 ez | 328nz2 | |
P Design 200 awnz | sz —
7 Proiotype 400 etz | amEz !
2 Revew 300 T | Az | %
9 w Testing 4.00 3129112 a4z ||
10 Preiminary 200 a2anz | aEwiz ——
a Gustomer 200 w2z Wz ! P
PP Final Review 800 iz wnz | Y
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6.8 Formatting pictures and text boxes

Formatting pictures and text boxes
Formatting an item (such as a picture or text box) defines its background, border, and shadow. Here you
will format a text box by adding a border and shadow.

Steps:

1. Click the text box to select it, click the Format Selected button [ E@fmat Selected,
The Format Item dialog opens.

2. Click the Border tab.

3. In the Line area, enter 2 in the Size box.

4. In the Shadow area, enter 2 in the Size box.

Format ltem

.rDispIav Border | Font |

Background Line Shadow
Color: EI Color: - Color: '-|
Margin: i) '? Size: |2.00 r?' Size: 2 rf]
Transparent

Example
Corner
S Example Tex
radivs: 5]
(&) ( Set as Default Y ( cancel ?f—ﬁlﬁ"—ﬁ

Y

5. Click OK to apply your changes and close the Format Item dialog.

6.9 Including a legend

Including a legend

A legend creates a key to the bar styles used in the schedule. It lists the bar styles and allows you to
assign a name, or a label, to each bar style. You can create multiple legends in the Schedule View and
the Schedule and Resource Print Preview windows. In this case, you will enter a legend in the Schedule
View.

Steps:
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1. From the Insert menu, select Legend.
The Format Legend dialog opens.

w N

. In the Title box, enter My Legend.
. Click in the first row of the Bar Style column.

4. From the Bar Style drop-down list, select the bar you custom designed.
The white-striped bar appears in the table below.
5. Click in the Label column next to the bar in the table and enter Planning Activities.

Format Legend

[ Display = Font Border  Options ]

Title: My Legend W show
Bar Style: [ # ’n-ﬁ-] Component: | Scheduled "3’!
Bar Style Label

& Planning Activities

@

( Cancel jf oK a

6. Select the second row in the Bar Style column.

7 From the Bar Style drop-down list, select the blue bar with black endpoints.

8. Click in the Label column next to the blue bar in the table and enter Development Activities.
9. Click the third row in the Bar Style column.

10. From the Bar Style drop-down list, select the green bar with the white endpoints.

11. Click in the Label column next to the green bar with the white endpoints in the table and enter
Testing Activities.
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Format Legend.

[ Display = Font  Border  Options ]

Title: My Legend E Show
Bar Style: Component: [ scheduled E‘
Bar Style Label

* L Planning Activities

Development Activities

A Testing Activities

@ { cancel ) o)

12. Click the Font tab.

13. From the top drop-down list, select Legend Title.

14. Click the Bold button.

15. Click OK to apply your changes and close the Format Legend dialog.

16. Using the Arrow tool, drag the legend to a location in the timeline graph where it is not covering any
bars or items.

First Cuarter Seo
- 5 March 2012 A
S 047 oty Name Duraton | StartDate | Finish Date i
: Mon | Tues | Wed | Thur | Fn | Sat | Sun | Mon | Tues | Wea | Thur| Fn | Sat | Sun | Mon | Tues Wed | Thur  Fi | Sat | Sun | Mon | Tues W

12 |18 |14 |15 18 |17 1@ |19 20 2 2 2 |24 |2 26 o 28 |2 30 | 3 |1 2 |3 4

1 w Planning 4.00 3MzHz | 36Nz |

Brainstorm 200 a2z ECE- I 3 * Thess desclinea are Srshilaf

2 fo meeling our goals.

3 Research 300 ananz sz L 3 »

P Budget 600 AR AR I >

5 w Development 8.00 39z | 3z8M2

a Desgn 2m aanz | a2z —

7 Pratotype a0 saiiz | azanz

P Review 100 N2 2EZ I % E——

My Legand
P v Testing 400  329M2 | 442
| L 2 # | Planning Activties ! { =3
10 Prefminary 200 329h2 301z o e
- T Develcpment Activitias
Fi Customer z00 iz iz P
PE Final Rzview ann Az Wz I Ay Tasiing Ackiibes Y

6.10 Adding headers and footers

Adding headers and footers

The Schedule, Resource, and Calendar Views all have the capacity to show headers and footers that
appear when you print that View or access that View’s Print Preview window. This allows you to include
information such as the file name, date, and page number on printed pages.

Steps:

1. From the View menu, select Header and Footer.
The Header and Footer dialog opens.

2. From the Format drop-down list, select Header.
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3. Select a cell in the right table.

4. From the Insert into Cell drop-down list, select Time (12 Hour).
5. Select a cell in the left table.

6. Enter the word Draft.

Format
Draft 140 PM
Left | Center | — ~ Right |
Draft m m = TimeToText{[Time], True) m
S e S
'y l &
v v v
Insert into Cell: [ - Auto Text -

L"i ( Copy All )

Display Options: [ All Pages

#(

)| ( Paste All 3

@

7. From the Format drop-down list, select Footer.

8. Select a cell in the middle table.
9. From the Insert into Cell drop-down list, select File Name.

( cancel ) (o)
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—
Draft Tutor3 fis 1:40 PM
Left | Center | Right |
Draft m = [File Name] m = TimeToText{[Time], True) m
i . ¥
v v v
Insert into Cell: [ - Aute Text - 3 ( Copy All )
Display Options: [ All Pages L%q( Font... j [ Paste All )
® ( cancel ) el

10. Click OK to apply your changes and close the Header and Footer dialog.

6.11 Previewing the customized schedule

Previewing the customized schedule

39

You are done! You now have a customized schedule with new bar styles, different text styles, text

boxes, and a picture.

Steps:
1. Click the Print Preview button.
The Print Preview window opens.
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(@00 - Tutor3.fts =
|
e Oraft Tutord fts 11:47 PM| -
Actidly Name St Sobern e D Mon  Tues Wed Thur Fri Sa:dar::r?‘]'i{cn Tues Wed Thur Fri Sat
Planﬂing 5 TS T 12 13 14 15 16 17 | 18 18 20 21 22 23 24
Brainstorm 200 2z | a2 4 * I ms:;dx:fﬂ"z::z:f:"“ﬂ
Research 3.00 ananz sz L 3 L )
Budgeat 0.00 anen2 anenz2 -
Development 8.00 31912 3/28M2
Design 2.00 anan2 22 o——
Prototype 4.00 320012 322
Feview 3.00 ar2en2 aizen2 e My Legand
Testing 4.00 3/29112 4/4112 | !
Preliminary 200 28012 a2 * - Rlaing Aot
Customer 200 a2 a2 Beveoment Ackviiog
Final Review 0.00 414112 4l4n2 o e 4 Testing Activities
6.12 Finishing Tutorial 3
Finishing Tutorial 3
You are done with Tutorial 3. You now know the basics of customizing the appearance of your schedule.
To close the Tutor3 file:
1. From the View menu, select Schedule.
The Schedule View opens.
2. To close the Tutor3 file, from the File menu, select Close.
3. Click No to close the schedule without saving your changes.
To start the next tutorial:
1. Go to Tutorial 4: Scheduling Dependencies.
-or-
Return to the Tutorial Contents.
7 Tutorial 4: Scheduling Dependencies
71 Scheduling Dependencies - Intro

Tutorial 4 - Scheduling Dependencies

This tutorial shows you the different ways to create dependencies, or links, between activities and
discusses the effect these links have on bar behavior.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor4.
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7.2

7.3

7.4

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor4". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

What is linking?

What is linking?

Linking two activity bars creates a dependency between activities. When an activity bar is mowved, it can
affect all bars linked to it. Links may be created from the start or end point of one bar to the start or end
point of a second bar, which is to say that FastTrack Schedule supports Start to Start, Start to Finish,
Finish to Start and Finish to Finish links.

Once bars are linked, you can set the Lead or Lag time between activities to determine how much one
activity may slip before it affects another.

Drawing links

Drawing links
You can use the Link Bars tool to create dependencies between bars.

Steps:

1. From the Tools control, select the Link Bar tool. =
2. With the Link cursor showing, click the END POINT of the Brainstorm activity bar and drag to the
START POINT of the Research activity bar.
3. To drag the linked bar, select the Arrow tool, and drag the MIDDLE of the Brainstorm activity three
days to the right.

You will know you have selected the middle of the activity when you see a cursor with arrows pointing
in both directions. The Research activity moves when you mowe the Brainstorm activity. In the Edit
menu, select Undo to return the bars to their place.

March 2012 Apr
= AT actiiy Name Durabon | StartDaste | Finish Date |Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed
12 |13 |14 |15 |16 |17 |18 |18 |20 |21 |22 |23 |24 |25 |26 |27 |28 |20 |20 |21 |1 |2 |3 | 4
4| | | |Franning 400 | 3nzn2 ez | | T T T T | 17 1 T T | I
Mz | Brainstorm 200 iz Widz ;\‘—
3 Research 2.00 3n4anz 1512 | -
| 4 | Budget 0.00 G EME | -
s w | Deveicpment 8.00 ez vzrz | |
| g | Design 200 iz 2012 | ——
7 Frofotype 250 azinz sz || R —
| 8 | Review 200 26T 2812 | S——
3 w | Testing 400 3282 Wz |
10 Prelminary 200 zanz 3012 | et
|44 Customer 2.00 aj2nz Az | A
| 12 | Final Review 0.00 ANz Az | Q

Linking selected bars

Linking selected bars
You can select bars and click the Link button to create dependencies between bars.
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7.5

Steps:
1. Hold down the Shift key and click on the Design, Prototype and Review bars to select them.
2. Click [21, the Link button.
All three activity bars are now linked. The default link type is Finish to Start with a Lag/Lead of 0, but
you can adjust this in the Information Form for these activities.

March 2012 Apr
= AT actiiy Name Durabon | StartDaste | Finish Date |Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur Fri | Sat | Sun Mon Tues Wed

12|13 |14 |15 | 16|17 |18 |18 |20 |21 |22 |23 |24 |25 |26 |27 |28 |20 |30 M |1 |2 |3 |4

1 | |Franning 400 | 3nzn2 ez | | T T T T | 17 1 T T | I I
———

2 | Brainstorm 2.00 2Nz 3132 '_'—'r__..:\‘___.

3 | Research 200 a4z &2 | ]

i | Budgst 000 a2 AHEAZ | >

s w | Deveicpment 8.00 3Haiz vzz | |

& | Design 200 ANz 2012 | _\'

’ | Prototype 250 a2z 2312 | —— |

F | Faview 300 IENZ T | s —————

3 w | Testing 400 3zaiz Wz |

| 10 | Preiminary 200 22012 3012 | o

|44 | Customer 2.00 a2z a3z | A

12 | Final Raview 0.00 FITF Az | &

Creating links in the Information Form

Creating links in the Information Form
You can create dependencies between activities in the Information Form.

Steps:
1. Click in the Information Form action column of Row 10, the activity named Preliminary.
The Information Form opens in the Row tab.
2. Click the Bars tab.
3. Click the Bars>Links tab.
4. In the Activity Name column of the Successors table, choose "9-Customer" from the drop-down list.
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"Row | Bars
Bar I 8 ‘ — Duration: | 2.00 |’_1
[] Hidden o St'.rle:[ s : Fﬁ] "] Fixed Duration

[ Tracking Columns | Links | Assignments ]

0 Predecessors

«i| Row | Bar | Activity Name | Type | Lag/Lead |Link Duration |

1 Successors

w| Row | Bar | Activity Name | Type | Lag/Lead |Link Duration
8 un 9 [9- Customer 1] Finish-to-Start (FS) 0.00 0.00

Lag/Lead and Link Duration are in units of: Days

@ [/ [ (] 31 (o

5. Click Close to close the Information Form and apply your changes.
The activities Preliminary and Customer are now linked.

March 2012 Apr
=l i X4 Activity Name Duration | StartDate | Finish Date |Mon Tues Wed Thur| Fri | Sat | Sun Mon Tues Wed Thur| Fri | Sat Sun | Mon Tues Wed Thur| Fi | Sat Sun Mon Tues Wed
& -

12: (13 |14 |18 |16 |97 |18 | 18 [ 20 |21 [ 22| 23 |24 |25 |26 |27 |28 |28 |20 (@1 | % | 2|3 |4
1 | Panning 4.00 ETFIF ECCF T i
2 Brainstorm 200 | sz 13Nz E | S |
3 Research 200 a4z ERTE) ] I |
. Budget 0.00 36Nz 31612 - |
s | w | Development B.00 EGETF Wzaiz i
& Design 200 | amanz 2012 _\‘ | | |
= Frototype 250 32inz azanz — | |
8 Rewview 300 | w2Enz | azenz | O T T T —— |
0 w |Testing 4.00 29/12 i1z
10 Preliminary 2.00 29012 3012 h—i\_\_\ |
al | Cusiomer 200 a2z Az i I T i
2 | | Final Review 000 | amanz Aanz | O T — 1 1 1 | [T

6. Click in the Information Form action column of Row 11, the activity named Customer.
The Information Form opens in the Row tab.
7. Click the Bars tab.
8. Click the Bars>Links tab.
9. In the Activity Name column of the Successors table, choose "10-Final Review" from the drop-down
list.
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Bar ID 9 |

 — ‘ Duration: 'ﬁ' fﬂ

Bar Style: | = 3] "] Fixed Duration

[T Hidden

[Tracking Columns | Links | Assignments ]

1 Predecessors

«| Row | Bar | Activity Name | Type 1 Lag.FLead_ ILink Duration |
ﬁ 10 2 8 - Preliminary Finish-te-5tart (F5) Q.00 0.00

1 Successors

~| Row | Bar | ~ Activity Name | Type | Lag/Lead |Link Duration |
8 12 10 [10 - Final Review [%] Finish-to-Start (F5) 0.00 0.00

|Em:er or edit the successor bars' data. |.1mj Link Duration are in units of: Days

® [ (€1 5] O] ( done )

10. Click Close to close the Information Form and apply your changes.
The activities Customer and Final Review are now linked.

| March 2012 Apr

f‘ e ﬁJAI Activity Name Duration Start Date Finish Date | Mon (Tues Wed Thur| Fri | Sat  Sun Mon Tues Wed Thur| Fri | Sat | Sun | Mon Tues Wed Thur| Fr | Sat | Sun  Mon Tues Wed
|l 12 (93 |14 [ 18 |16 |97 |18 |18 |20 |21 [ 22| 23 (24 |25 (26 |27 |28 |28 20 (91| v | 2|3 |4
1 w | Planning 400 | 3dzz E-TE -T2 T 0 — — [
2 | Brainstorm 200 | sz 33z E | S |
3 Research 200 Ananz 3162 — |
4 Budget 000 | adenz EME | | | " I |
s | | w | Deveiopment B.00 ez a2 |
& Design 200 | amanz 2012 | | | | I _\' | | |
v Prototype 250 32inz azanz — | |
8 Review 200 | amenz 2812 | | | | I I | | | | I ""‘“..__'_', | |
0 w | Testing 4.00 29/12 i1z !
- pum e T S O P O M S PO O PO | — T —r |
al | Customer 200 a2z aiBfz T =
12 [ Final Rewew 000 | aanz Az | | | | I I | | | | I I | | | | I | | '&'

7.6  Finishing Tutorial 4

Finishing Tutorial 4
You are done with Tutorial 4. You now know the basics of scheduling dependencies through linking,
locking, and chaining.

To close the Tutor4 file:
1. To close the Tutor4 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:
1. Go to Tutorial 5: Tracking Progress.

Copyright © 2010, AEC Software, Inc. All rights reserved.



Tutorial 4: Scheduling Dependencies 45

8.1

8.2

=-Or-
Return to the Tutorial Contents.

Tutorial 5: Tracking Progress

Tracking Progress - Intro

Tutorial 5 - Tracking Progress

This tutorial shows you how to track the progress of activities by entering their scheduled dates, revised
dates, and work-in-place with actual dates and % complete.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor5.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor5". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

What is progress tracking?

What is progress tracking?

Thus far in the tutorials you have simply dragged activity bars to a new position in the timeline graph
when their dates have changed. Some projects, and some companies, call for a way of tracking these
changes. This is called progress tracking.

At all times, FastTrack Schedule automatically tracks the progress of activities as three sets of dates:

- Scheduled — Dates that reflect when your schedule was originally planned, also called the "baseline"
or "promised" dates.

- Revised — Dates as they are currently projected, accounting for adjustments since the project began.
- Actual — Dates as they actually happened, also tracked as a percentage complete, or "work-in-place."

Each set of dates (or "component") can be displayed within a single bar style and each has its own tool
for editing that component. The bar styles in this schedule have been formatted to Always Display the
Revised Element even when the revised dates and times match the scheduled dates and times.

Example: As an example, the graphic below represents what a schedule would look like when you first
plan the project. At this stage, the activity bars represent the Scheduled starts and finishes. In this
example, the Scheduled component is the top bar, the Revised component is a bar just below the
Scheduled component, and the Actual component is a different color fill in the Revised bar. For the
Milestone, the Scheduled, Revised and Actual are represented by different fill colors.
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Mar 12
=l At i Finish Rewvised Rewaad Actual
2 @47 ActvityName | StertDate| ho. | giar Date | Finish Dae | StartDate | % Complete = " = =
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1 |____.
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Now take a look at the schedule since work has begun. We have completed the first activity,
Brainstorm, as shown by the yellow Actual fill color. We can also see that it was completed on time —
the Scheduled, Revised, and Actual are all the same. We have also completed 50% of the Research
activity, as shown by the yellow Actual fill color in half of the Revised bar.

Notice that the Research activity's violet color Revised bar is shorter than the Scheduled bar. This shows
that while the activity will take shorter than planned; it has been revised to end later. Also notice that
links always connect the Revised elements of activity bars.

Mar 12
=l At i Finish Rewvised Rewaad Actual
B e - Acivity Name  StartDate | po. | sy faie | Finish Dals Start Date | ° COMAlEte = " = =
| |Fianning | aMaMz | WEeMZ | a2z | @Iz | 3dEMZ | 50% I
1
Brainaborm 22 | FEhZ | aAan2 SN2 | aAanz 100% |—]
2
Rezearch | anenz | a20nz | aMonz 22 | ANz | 50% |
3 e
Buidget | a2z | 3Rz | amanz ez | | 0% | i |
‘ ——
"jna-,eewnam | 3MEM2 | 44Nz 3MEnz 4z | | % I
[
Design I8ME | w2anz | ananz 2ane [ PR—
[
|| Prototype | a2z | 4anz | aEenz anz | [ % | L
T —_—
Review |4z | 4ihz | Az 44z | % | [ -
g .

The last schedule shows that all activities have been completed. Their bars show the difference between
their Scheduled and Revised dates.
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8.3

Mar 12
1=l At ; Finish Rewised Rewised Achual
3 (] Activity Hame | StartDats | noo | Sian Date | Finish Date | Start Data | 2 ComAlste = o s =
5
".'P.ar.m.-g | 3MzMz | M2EMZ | aMznz IIMZ | aaMz | 100%
1
. !
Brainstonm nahz asen2 a2z sz a2 100k E—
% |
| Research ez 2z aanz 22 a2 100%: [
3 g

| Budget a2 | W26M2 aahz Tz 2anz 1004

v | Development 1812 42 31812 4612 31812 100% |

| Dasign nanz aaanz ananz arzanz ananz 1003

‘)' I

| Prototype a2 4/aM2 eanz2 4712 azanz 100% |

|

| Review Az | ANz FITF] B2 FITF] 100%

Using Revised dates

Using Revised dates

While the three components can be displayed in thousands of ways, in rows 2, 3, and 4 they will be
displayed as a black color bar for Scheduled, a violet color bar for Revised that is always displayed, and
a yellow fill color for Actual. In rows 6 and 7, they will be displayed as a green color bar for Scheduled,
an orange color bar for Revised, and a purple fill color for Actual.

With the Scheduled dates in place and an understanding of the bar styles used, you are ready to track
the progress of your activities. Let's say that because of conflicts, the Brainstorming activity cannot
begin when scheduled. You must revise it to start later, slipping it a few days.

You can change the Revised dates by typing in the Revised columns, but here you will use the Revised
tool.

Steps:

1. From the Tools control, select the Revise Bar tool. =

2. Position the cursor in the MIDDLE of the Brainstorm activity bar and drag to the right 1 day to
03/13/12.

3. Select the Revise Bar tool again and drag the END POINT of the Design activity bar to the right 3
days to 03/26/12.
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Notice that the Prototype bar also shows revisions. This is because it is linked to the Brainstorm bar and
when you change the Revised dates you also revise the dates of the linked bars.

48 FastTrack Schedule 10 Tutorials Manual
= @47 ActviyName  Start Date
| |Pranning EGELF]
1
Brainsborm 122
2
Ressanch IEM2
3
Buidget | a2
4
v | Dewelooment EGERF)
5
Design ananz
&
Prototype 2612
T
Renaw TG
]
8.4 Resetting Revised dates

Resetting Revised dates

If you make a mistake or your revisions no longer apply, you will want to reset the Revised dates back to
the Scheduled dates. For instance, if it happens that the Prototype activity is not affected by the revised
slip of the Design activity, you need to return it to where the Scheduled dates and Revised Dates are the

same.

Steps:

1. To reset the Revised dates, select the Prototype activity bar with the Arrow tool.
2. From the Tools menu, select Progress Tracking, and choose Reset Revised from the submenu.
The Prototype bar returns to where the Scheduled dates and Revised Dates are the same.
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8.5

Mar 12
=l At i Finish Rewvised Rewaad Actual
) (] - Acivity Name  StartDate | po. | sy faie | Finish Dals Start Date | ° COMAlEte : " = =
| |Pranning | aMaM2 | ¥2eMZ | 32 | aETH2 | | % .
1 | ———
Brainstorm ["aAzhz | #H8hZ | ananz ez [i8
2 uT-—u
Research [ anMenz | mEoMz | aahz aznz | | [ 1Y
3 e —
Buidget | a2z | 3Rz | amanz ez | | 0% | h |
‘ ——
w | Deveicpment IMEMZ | 4ANZ oMz 44z 0%
5
Design 3EME | AZaNz | ananz A2EME % F—
y =z
Profotype [TaETHZ | 4MAZ | aEhz A4z | [ % [
'IF —n
Review |4z | 4ihz | Az 44z | % &
8 .

Using Actual dates and % Complete

Using Actual dates and % Complete

An activity's Actual dates and % Complete are interrelated - they both represent "work-in-place." As an
activity is worked on, it is first given an Actual Start date, then an increasing % Complete, and when
completed, an Actual Finish Date and an Actual Duration.

Steps:

o,

1. From the Tools control, select the Percent tool. =
2. Position the Bar Percent Complete cursor in the middle of the Brainstorm activity's blue Revised bar
and click your mouse button.

3. If the activity's % Complete column does not show 50%, select the value and type 50.

4. Press the Return/Enter key.
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8.6
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You do not need to be tracking all three sets of dates in order to use % Complete.

Designing Scheduled, Revised, and Actual bar display

Designing Scheduled, Revised, and Actual bar display
You have seen how to track a bar's three components, so now you can learn how to design the three
components.

Steps:
With the Arrow tool, click the Brainstorm activity bar to select it.

1.
2.

©O~NO U AW

On the Format menu, click Bar Style.

The Format Bar Style dialog opens.

. Click the Show All Components While Editing box.
. From the Component drop-down list, select Revised.

. From the Part to Edit drop-down list, select Revised Start Point.
In the Shape area, select the circle point style.

. Select Actual from the Component drop-down list.
. In the Fill area, choose a shade of green from the Color box.

. Click OK to apply your changes and close the Format Bar Style dialog.
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9.1
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Changing the display of bar style components gives you complete flexibility in tracking and displaying
Scheduled, Revised, and Actual dates and times.

Finishing Tutorial 5

Finishing Tutorial 5
You are done with Tutorial 5. You now know the basics of tracking an activity’s scheduled, revised, and
actual dates.

To close the Tutor5 file:
1. To close the Tutor5 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:

1. Go to Tutorial 6: Using the Work Calendar.
-0r-
Return to the Tutorial Contents

Tutorial 6: Using the Work Calendar

Using the Work Calendar - Intro

Tutorial 6 - Using the Work Calendar

This tutorial shows you how to use Work Calendars to define typical and non-typical, or exceptional,
work days for the project as a whole and for a resource. You will also learn how to handle contradictions
between the project and resource work calendars, to display the work schedule in the timeline graph,
calculate durations in work units, and to drag activity bars according to the work schedule.

To open the practice schedule file to be used while taking this tutorial:
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1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.
2. Select the FastTrack Schedule file Tutor®6.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor6". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Defining a Work Calendar

Defining a Work Calendar
In Fast Track Schedule there are three types of work calendars: project, activity and resource. You

assign just one calendar to the project, but any activity can be assigned a separate calendar and every

resource has its own work calendar. Each of these calendars is edited in the Work Calendar dialog and

each of these calendars is completely customizable.

Work calendars allow you to define typical work days and exceptional days for the project, each

resource and any activity.

Work Calendars helps you accurately track the amount of time available for work on activities. Once

Work Calendars have been defined, you can utilize them in several ways:

- To display the work schedule in the Schedule View timeline by hiding and/or shading non-work times.
- To help you schedule activities during work times only.
- To calculate durations in work units.

There are four key elements of the Work Calendar: Base Work Days, the [selected] Calendar, Typical

Days, and Specific Days.

This Does this:

element:

Base Work Determines how durations of work days are calculated. This is
Day only used in calculations. You set this number in the Project
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tab of the Document Preferences dialog.

[Selected] Determines the calendar you assign to a project, activity or
Calendar resource and from which you may build a custom calendar.
Choose from: Standard - 8 hour work days Monday -Friday, 24
Hours - 24 hour work days seven days a week, Night Shift - a
40 hour work week from 11 PM - 8 AM, and any custom

calendars you have created.

Typical Allows you to set up a work schedule in which each day of the
Week Day week might have different hours, for instance, a Monday might

differ from other days.

Exceptions Defines the specific days of the year that deviate from the base
work day or typical days. Each specific day can have its own
set of hours or no hours. For example, you might want to define
holidays as specific days. Specific days are listed in the

Exceptions table and can be given a descriptive name.

If you choose to calculate durations in 24-Hour Calendar units, the Work Calendar is no longer being
used in the schedule.

In these steps, you will create a new work calendar, define March 16, 2012 as a non-work day, and set
this new calendar as the Project Work Calendar.

Steps:
1. From the Project menu, select Work Calendars.
The Work Calendars dialog opens.
2. Click the New button.
3. In the New Work Calendar dialog, be sure Standard (Project Calendar) is selected in the Copy
Calendar option, and enter"Product Titan Launch".
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9.3

4. Click OK to close the New Work Calendar dialog.
5. In the Define Specific Days area, select March as the month and 2012 as the year.
6. Select day 16 in the calendar.
7. Click the Clear Day button.
The Work Shift Details table will now contain no start time or finish time.
8. In the Description field of the Exceptions table, enter "Company Holiday" beside the date 3/16/12.

-

9. Click OK to apply your changes and close the Work Calendars dialog.
10. From the Project menu, select Project Information.

The Project Information dialog opens.
11. From the Calendar drop-down list select Product Titan Launch.

12. Click OK to close the Project Information dialog and save your changes.
Note that March 16th is now shaded as a non-work day in the timeline.

Clicking a day in the calendar or Typical Week Day area displays the work hours defined for that day in
the Work Shift Details table. Here you cleared all of the work hours to make 3/16/12 a non-work day.
You could, however, define new work hours by entering up to eight shifts, or "periods," of work time.
Each period must be a continuous period of time.

In addition to defining the work schedule of specific days (as abowe), you can also define the work
schedule for typical days of the week. This allows you to define a different work schedule for each day of
the week.

Displaying the Work Calendar

Displaying the Project Work Calendar
The appearance of the Project Work Calendar in the timeline graph is defined in the Display tab of the
Format Schedule View dialog.

By default, timeline graph shades all days that have no work defined in the project work calendar. In
addition to the typical Sundays and Saturdays, the specific day that you changed, March 16, 2012, is
also shaded.

We will now change the setting from shading non-work days to hiding them.

Steps:
1. From the Format menu, select View.
The Format Schedule View dialog opens in the Display tab.
2. In the Timeline Columns Display area, select the Hide Continuous Non-Work/Shade Other
option.
3. Click OK to apply your changes and close the Format Schedule View dialog.
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]

The timeline graph now hides all typical non-work days that are continuous with the weekend. All other
specific non-work days, including Friday, March 16, 2012, are shaded when you select this option. If
every Friday was deemed a non-work day in our Product Titan Launch work calendar, then all Fridays
would be hidden also.

9.4 Creating a task specific Work Calendar

Creating a task specific Work Calendar
Any activity in your schedule can be assigned its own work calendar.

You will now create a new work calendar for the activity "Prototype". Currently this activity has a Start
Date and Time of 3/21/12 at 8:00 AM and a Finish Date and Time of 3/23/12 at 5:00 PM.

Steps:

1. In Row 7, double-click the bar for the activity Prototype.
The Information form for that activity opens.

information (Prototype : Row 7

! Row | Bars
skt Duration: 3.00 r?'
[T Hidden ’ . =
Bar Sr\rle:[ hﬂ ] Fixed Duration
{ Tracking  Columns  Links  Assignments ]
Start Date Start Time Finish Date Finish Time Duration
Scheduled 03/21/2012 || 8:00 AM |7 03/23/2012 7| 5.00 PM | 7| 3.00 |3
Revised 03/21/2012 |7 8:00 AM | 7| 03/23/2012 7| 5.00 PM |7/ .00 3!
Actual |1| |:| |:| |:| r?'
% Complete o.o0% [ Priority (Days)
Constraints Calendar
TvPe: [ start On Or After Fed [ None 4
) I: New... :I : Edit...
Constraint Date 03/21s2012 |:| B
Constraint Time 8:00 AM | 7| [] lgnore Resource Calendars
& [ [ [ 1] T

2. In the Calendar area of the Prototype Information Form, click the New button.
3. In the Calendar Name option, enter Titan Prototype.
4. From the Copy Calendar drop-down list, choose 24 Hours.
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Calendar Name: {"ﬁtan Prototype I

Copy Calendar: [ 24 Hours I-ﬂ

® [ Cancel jw

5. Click OK to close the New Calendar dialog.
Note the new Finish Date and Time.

BarID 5 S %00 i
L Hidden Bar Stvle:[ H‘-i [ Fixed Duration
][-:chiling--l Columns Links  Assignments ]
Start Date Start Time Finish Date Finish Time Duration
Scheduled 03/21/2012 7| 8:00 AM | ™| 03/22/2012 |7 8:00 AM | 7| 3.00] [}
Revised 03/21/2012 (%] | 8:00 AM |7 03/22/2012 % | 800 aMm| 7| | 3.00 !
Actua ol - ol - o
% Complete | 0.00%| 2] Priority | | {Days)
Constraints Calendar
TYPE: | Start On Or After k4 [ Titan Prototype b
Constraint Date 03/21/2012 ¥ (Newi N &die.c )
Constraint Time | 8:00 AM fl:l [ Ignore Resource Calendars

@ G )

6. Click Close to close the Information Form.
Note that Prototype now has a calendar icon in its Information action column denoting it's use of a
work calendar different to the specified Project work calendar.
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March 2012 Apri
_,: @‘ Actvity Name Duration Start Date Finigh Data M T|W T|[F [T W [T F| M T WT| F M T W
273 4| 18 |6 e 30 | 21 | 22033 |36 | 3T |28 2 30| 2 3|4
P w |Fianning 4.00 2z 392 ! !
2 | Brainstorm 200 2z EURTEH] — |
| [
3 Research 200 anz MGH2 | — |
. | Budget 0.00 ] 302 | |
5 w | Development .00 EGETF zaM2 | |
8 | Design 200 ez 2012 | —
7 = | Prolotype 200 322 w22H2 i p—
8 | Revew 3.00 26 W2BMZ | rE————
g9 v Testing 5.00 2|2 Adii2 |
10 | Preiminary 200 HPANE kT T e | |
1 | Customer 200 33012 Az i | —
12 | Final Review 0.00 AAZ Az | | -

You can see that the Prototype baris smaller now and that, though the activity still has a duration of "3.00," it
now has a Start Date and Time of 3/21/12 at 8:00 AM and a Finish Date and Time of 3/22/12 at 8:00 AM.
Because a work day s still defined in 8 hour increments, the duration calculated in days equaling 3 means that
that duration represents 3 sets of 8 hours or 24 total hours. Now that Prototype has a 24 hour calendar, it's
duration still displays in regards to the defined work days, but now all 24 hours can fitinto one 24 hour time

period - thus the new finish time.

Finishing Tutorial 6

Finishing Tutorial 6

You are done with Tutorial 6. You now know the basics of defining and using the work calendar.

To close the Tutor®6 file:

1. To close the Tutor®6 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:

1. Go to Tutorial 7: Filtering and Sorting.
-0r-
Return to the Tutorial Contents.

Tutorial 7: Filtering & Sorting

Filtering and Sorting - Intro

Tutorial 7 - Filtering and Sorting

This tutorial shows you how to use filters and sorts to hide and rearrange rows according to the data

they contain.

To open the practice schedule file to be used while taking this tutorial:
1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files

from the submenu.
2. Select the FastTrack Schedule file Tutor?7.

Important:
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10.2

10.3

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor7". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Applying a filter

Applying a filter

Filtering activities allows you to hide and select rows based on criteria that you define. It is a way of
searching rows for information. For each schedule, you can define a list of filters that search for data in
the schedule's activities. Filters are stored in the Filters dialog.

Steps:
1. On the toolbar, click Filters, and choose 100% Complete from the drop-down list.
March 2012
—4 @ ‘- Activity Name Duration Start Date Finish Data % Gomplate: | 5 (M | T |W|T|F |5 (& (M|[T|W|T|F|5|85 M| T W|[T

| | | | | ) | 1‘_115 1 014 15 e 17 ‘5_10_70_2' 71&_?334 25 HU_R'-’_?H-_W

1 w | Planning 4.00 ECFITF] ELCEH 100% T
I | Brainstorm 300 ERFTF Iz 100% —

3 Research 300 EUETH G2 100% || —
| | Budget 0.00 162 I8z 100% | &

5 w | Develcpment 8.00 1Az EFCEH 100%
| & | Design 00 19z a0z 100% ——

7 Frolotype 4.00 AB0Z T 100%
| P | Review 200 2262 2812 100% | | | ———

By default, filters look at the information in the activities that are currently visible and those that are
hidden. If you wish to create a filter that looks for information that is visible only, deselect the "Expand
All Prior to Filtering" and the "Restore All Prior to Filtering" options in the Options tab of the Define Filter
dialog.

Defining a filter

Defining a filter
Filters are defined in the Define Filter dialog. You can think of the filter's criteria as questions the filter
asks of each activity. Each question has three parts:

a column in which to search
- a way of comparing the column data to values
- a value to look for

For this filter, you will define criteria that ask the question, "Which activities have in the Manager
column, a value equal to Smith?"

Steps:

1. On the toolbar, click Filters, and choose Define from the drop-down list.
The Filters dialog opens.

2. Click New.
The Define Filter dialog opens.

3. Enter Smith’s Projects in the Filter Name box.

4. In the Apply area, select the Column/Value Criteria option.

5. In the Row Options area, select Matching Rows Only.
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Define Filter

Filter Name: ESmith's Projects

[Clptinns | Column /Value Criteria Date/Time Criteria |

Apply: Matching Rows Display
%) Column/Value Criteria Bar Options:
() Date/Time Criteria %) All Bars in the Row
D Column/Value Criteria AND Date/Time Criteria D Matching Bars Qnly
D Column/Value Criteria OR Date/Time Criteria Row Options:
{*) Matching Rows Only
W Expand All Prior to Filtering () Matching Rows AND:
™ Restore All Prior to Filtering Parents -
E Apply All Bars Range After Filtering |
Filter A Row When:
{*) Any Bar in that Row Matches Iﬁ‘
() First Bar in that Row Matches 1
() All Bars in that Row Match | |
I | l
o) ( cancel ) E‘—ﬁlt"—a
!

6. Click the Column/Value Criteria tab.

7. To define the column in which to search, in the table, click Select Column in the first Column cell.

8. When the drop-down list that appears, type an "m" to scroll to Managers, then click to select it.

9. Click the first Test cell to select it.

10. From the drop-down list that appears, select the equal sign (=).

11. Click the first Value cell to select it.

12. Select Smith from the drop-down list to enter the value against which all activities will be compared.
If a Value List had not been created for this column a value would have to be typed in.

Copyright © 2010, AEC Software, Inc. All rights reserved.



60

FastTrack Schedule 10 Tutorials Manual

Filter Name: |Smith's Projects

| Options | Column/Value Criteria | Date/Time Criteria |

1] Column | Test | Value [ AndfOr | ﬂ_}
— - Caual.. [smth )

Select Column

Clear Table

Options

Insert Function/Column into Value: [ I-‘-i

@ ( Cancel ) oK )

13. Click OK to create the filter and close the Define Filter dialog.
14. In the Filters dialog, click the Select option to highlight the activities that match the criteria.
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._ il |

_ Filters | Menu | Break |
Smith's Projects H m

Previous Hour
Previous Day
Previous Week Duplicate...

Previous Month

. Delete...
Previous Quarter

Previous Year
Current Hour
Current Day
Current Week
Current Month

ERROOODOOCOOO®

000
[

Matching Rows
() Show
i) select

@ ( close ) i)

15. Click OK to apply the filter and close the Filters dialog.

March 2012 April 2012
=i 0 Activity Name Duration Start Date FinichDate | % Complate |5 M | T W |T|F |5 |85 |M|T|W|T|F|s |5 M T W/ T|F|s|s/M|T|wT
19042 13 14 15 16 17 1B 19 30 21 22 23 4 25 26 27 28 26 30 N 1 2 3 4 8
1 w | Fianning 4.00 22 3612 100% T [
p——ar |
2 Branstorm Th0 o TAan T —_—
[
3 Research 200 a2 sz 100% | —
4 Budget 000 ez EGLGF] 100% &> |
5 w | Development 8.00 | ANz WAZ | 100% | | | 'i
P Design | 200 [ ananz 202 | 100% - | | | |
7 Frototype 400 W20/12 ANz 100% —— |
P Review | 200 | EVTTR DT | 100% T 1 [ | 1 | m—| |
° w | Testing 500 I 328142 Alanz I % I L
10 Preiminary I Z00 I Eanz w2911 % | —| | | |
“ Customer 300 T 43z % | | | 1 | L e—t— |
12 Final Review | 000 | Alaz A4z % »|

Because the Restore All Prior to Filtering option is selected by default in the Define Filter dialog, all rows
are restored from the last filter before the new filter is applied.

10.4 Hiding activities

Hiding activities
You can also hide activities without using the Filters dialog by using commands in the Edit menu. Here,
since activities are already selected from the last filter, you will hide them by choosing Hide Selected.

Steps:
1. From the Edit menu, select Hide Selected.
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10.6

March 2012 Aol 2012
4,1'64‘ Activity Name Duration Start Date FinichDate | % Complate (& (M | T (W |T | F |8 |8 M [T W|[T F|5 s M| T W[T | F|[s 8 (M T |w T
19 12 12 (14 15 16 17 (18 19 20 29 |22 23 24 25 26 27 28 2630 M 1 2 + | 4 5
E e I — b ——J — | E— R el R e A S DL S S
& Budget 000 3e6nz nenz 100% -
s w | Develooment 800 ECTTH 2812 100%
| 6 | Design 200 31912 32012 00% ——
7 | Prototype 400 20112 2312 00
i | Review 200 22612 wzanz 100% e—
9 v Testing 500 dzmi2 442 0%
| 10 | Prefiminary 200 32802 3202 o% e —
PP | Customer 300 ETRITEF] FIETEFS % e
| 42 | Final Review 0.00 Aanz ARz 0% >
Restoring filtered activities
Restoring filtered activities
When you are done hiding rows and wish to see all of the activities again, you restore the schedule.
Steps:
1. From the Edit menu, select Unhide.
March 2012 Apeil 2012
J;'@“ Activity Name Duration Start Date FinishData | %.Complate [ [m [T |w [T |F |8 s |m|[T|w[T|F[a[s[m[T[w[T[F[e|s[m][T[w][T]|
11 12 12 (14 15 16 17 (18 19 20 21 (22 23 24 25 26 27 28 2630 31 1 2 ¥ | 4 5
E Ee—— d— }——) S| E— B e R LA KL ol R i B S DL S S E
| 2 | Branstorm 300 32z 3Nz 100% ]
2 | Research 300 1Az 62 100% [N
| | Budget 000 31612 316M2 100% la
5 v Development 8.00 1912 dzeinz 100%
| & | Design 200 ez 2012 100% —
’ | Prototype 400 20112 23z 100%
| 8 | Revew 300 32612 32812 o0t e———
2  |Tesiing 500 ELTTH wanz 0%
TS | Pretiminary 200 22812 w2912 0% o
11 | Customer 300 330012 43z 0% r———
| 12 | Final Review 0.00 Aaiz ANz % .

Restoring does not undo changes you have made to activities. It only shows hidden activities and returns
them to the Master Sort Order.

You should be aware that changes you make to the order of activities are not restored. Changes that
could affect the order of activities include: moving, deleting, inserting, cutting, and pasting rows.

Applying a sort

Applying a sort
Whereas filtering hides rows, sorting rearranges the row order based on information in an activity’s
columns. Like filtering, sorting is done on visible activities and can be temporary.

Steps:
1. On the toolbar, click Sorts, and choose By Duration from the drop-down list.
This sorts the rows by the values in their Duration column - lowest to highest.
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March 2012 Al 2012
%‘64‘ Activity Name Duration Start Date Finigh Date SComplate’ | & (M | T |W | T |F|S|&|(M|T|W|T|F|5|[S|M|T|W|T|F|[8|[8[M|T|wW|T
11 12 (13 (14 15 16 17 18 16 20 21 22 23 24 25 26 27 28 26 30 3 1 2 34 5
1 w |Planning 400 2z 3612 100% I
. Budget 000 F6n2 B2 100% "
2 Brainstorm 300 a2 a4z 100% e
|"a | Research 300 a2 ECLTH] 100% e
0 w | Testing 500 3282 4z (173
|42 | Final Review 0.00 44Nz Az % >
| 10 Pretiminary 200 VLT 22012 0% o
141 | Customer 300 33012 aranz % e
5 w | Develcgment 8.00 3z zanz 100%
P Design 200 3anz 2012 100% —
B Review 300 2612 328112 100% ———
| 7 | Prototype 400 320012 32312 100% JROT———

10.7 Defining a sort

Defining a sort
Sorts are defined in the Define Sort dialog. These steps create a sort that arranges activities in order by
their % Complete and Start Date.

Steps:
1. On the toolbar, click Sorts, and choose Define from the drop-down list.
The Sorts dialog opens.
. Click New.
The Define Sort dialog opens.
. In the Sort Name box, enter By % Complete and Start Date.
. In the Columns table, scroll down and select % Complete.
. Click the Show button.
. To sort the % Complete value in descending order, click the stair-step icon next to the name in the
Sort Order table to change it from Ascending to Descending order.
7. In the Columns table, scroll to the top of the table and select Start Date.
8. Click the Show button.

N

[©20¢; IF NNV}
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Sort Mame: By % Complete and Start Date
Set Sort Order

Columns f _ Sort Order [
Start Date 1 - % Complete h.
Start Date
Start Date 2 —v— a <
Start Date 3
Start Date 4
Start Date 5
Start Date 6
Start Date 7 -
Hide All
Start Date 8
Start Date 9
Start Date 10 0
o Applying this Sort Moves Rows
Start Time
Start Time 1 B Allow Rows to Mowve Anmywhere
Start Time 2 ¥ () Only Within Outline Levels
Start Time 3 v Lock Outline Levels Through Level: o ke

® I: Cancel ]E—ﬂ&—-’

9. Click OK to create the sort and close the Define Sort dialog.
10. Click OK to apply the sort and close the Sorts dialog.

| March 2012 Apri 2012

=i [ Activity Name Duration Start Dats FinlshData | % Complate (5 M | T |W [T |[F |5 |s (M [T |w|T|F|s|s|M[T|(W|[T|F|S|[8|M|T|W
I (12 (43 14 | 15 (16 (1718 | 19 | 20 |21 |22 |23 |24 |25/ 26 |27 |26 |20)30/31 | 1 |2 (3|4

o yr— i T L e

2 | Beainstorm 300 322 a4z 100% e

3 | Research 3.00 I amanz LU 1W00% —

. | Budget 0.0 a2 36z 100% >

P  |Development 800 | aHanz lzalz 100%

& | Design I 200 | anz 2012 I 100% |

7 | Prototype 4.00 I 320112 EVETF] 100%

8 | Review I 200 | 2612 2812 I 100% —

.  |Tesing 500 | azaiz 4az % ;

10 I | Prelminary I 200 | 2812 2912 0% A

11 | Customer 3.00 | 3@z Az 0% R il

B | Final Review T om | @z aanz % &

The schedule's activities are moved up and down into the new sort order. First they are arranged in
descending order by % Complete value and then the activities with the same % Complete values are
arranged in ascending order by Start Date.

The Sorts dialog also contains an option called Define as Master Sort that defines the selected sort as
the Master Sort order. Once a sort order becomes the Master Order of activities, you cannot return to
the original order. When you restore activities, they will restore to the current Master Sort order.
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10.8 Restoring sorted activities

Restoring sorted activities
Like filtering, sorting is temporary if you return to the Master Sort order by restoring the schedule.

Steps:
1. From the Project menu, select Restore All.
March 2012 A 2012
d,@‘ Activity Name Duraticn Start Date Finish Date %Complate | S (M [T | W|T|F|[S | S (M| T(W|T|F | 5[5 M|[T\ W|T|F|[5|S5 M|T w
1012 13 14 15 16 1T 1B 19 20 21 22 23 24 28 2 27 28 26 30 1 1 23 4
; 1S [P 1 < A R 5, sl i Bl ] B oot B ot S el B B R el
—
2 | Brainstorm 300 2z 14z | o0 —
P | Research 300 3z 382 100% O
4 | Budget 0.00 ez BME | 100% Lo
s w | Development 8.00 EGETH 3zaiz 100%
& | Design 200 anz 2012 | 1e0% —
7 | Prototype 4.00 2012 azanz 100% em—
8 | Review 200 2612 228M% | 100% | —
P w |Testing 500 zanz 442 [
| 10 I | Prefiminary 200 22812 22912 | 0% | | .
|44 | Customer 300 330112 732 0% R
|42 I | Final Review 0.00 Az Az | % | | | >

This returns the schedule to its Master Sort Order. Remember, restoring does not undo changes you
have made to activities. It shows hidden activities and returns them to the Master Sort Order.

You should be aware that changes you make to the order of activities are not restored. Changes that
could affect the order of activities include: moving, deleting, inserting, cutting, and pasting rows.

10.9 Finishing Tutorial 7

Finishing Tutorial 7
You are done with Tutorial 7. You now know the basics of filtering and sorting.

To close the Tutor7 file:
1. To close the Tutor7 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:
1. Go to Tutorial 8: Using Summaries and Calculations.

_or_
Return to the Tutorial Contents.

11 Tutorial 8: Using Summaries & Calculations

11.1 Using Summaries and Calculations - Intro

Tutorial 8 - Using Summaries and Calculations
This tutorial shows you how to use column summaries, summary graphs, and calculation columns.

To open the practice schedule file to be used while taking this tutorial:
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11.2

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.
2. Select the FastTrack Schedule file Tutor8.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor8". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Adding a column summary

Adding a column summary
Column summaries display the total, average, standard deviation, minimum, and maximum of values
currently visible in a column.

Steps:

1. Double-click the column heading of the Duration column.
The Format Column dialog opens.

2. Click the Summaries tab.

3. Select the Total option.

Format Column (Du zatinq}

[ Options Value List Display Font | Summaries 1

Column Summaries Summary Bar Values
[ Count [ Minimum None
M Total [ Maximum Count
[] Average ["] Standard Dreviation =) Total
Label Display Minimum
() Do Not Show Label Maximum
(Uses Column Justification) Average
© Show Label Standard Deviation
(Ignores Column Justification)
{7} Short Label
{7} Medium Label
") Long Labe|
Example:
i Total: 10.00 i

oo ( Cancel ) (o)
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11.3

4. Click OK to apply your changes and close the Format Column dialog.

March 2012 April 2012
4'1 [i8 Activity Name Duiration Start Date Finizh Date RateParDay [m |7 | w|T|Fl[s s m|[t|w|[r/els|s|m|[riw|[r|e|s|s|m|t|w
1213 |14 (15 116 | 1T | 18 {1620 |21 (22 32 |24 |26 (26|37 28|29 |30(31| 1| 2 |3 [ 4
I 1 | " Flanning Tfo0 znz | Jz0/H2 | $250.00( Ll T [ R ST el o (R
| | Brainstorm 300 2z EGTTE] $100.00)
2 —_
3 | Ressarch 300 Az sz LT ——
| 4 | Budget 300 EGLCTEF 22012 $75.00 | e
5 | Deveicoment 8.00 ERETF 2812 §265.00 | 1
I 1 1 I
P Design 20 3ohz 32012 $z5.00 | —
7 | Prototype 4.00 20012 23Nz $80.00 i
| 8 | Revew 300 32612 22812 $80.00 | e—
|s ':Tasﬁng 5.00 zBl2 i1z $175.00 I
10 Preliminary 2.00 azanz 3zanz ETE00 | Py
|44 | Customer 300 3012 Az §100.00] | e
| 12 | Final Review 0.00 ajanz Alalz | -
Total: 23.00 12|13 | 14| 15| 16 | 17 | 18| 18 | 20 | 24 | 22| 23 24 |25 |26 | 27 28 2030 | |1 |2 |3 |4

This displays the total of all values visible below the Duration column.

In order to view column summaries, the Column Summaries & Timescale (Bottom) option must be
selected in the Columns tab of the Define Layout dialog.

Defining a calculation column

Defining a calculation column

You can add columns to your schedule that derive their values from other column. These are called
calculation columns. Instead of entering values for a calculation column, you set up a statement that
tells FastTrack Schedule to use operations and functions to calculate the value.

Steps:
1. Click the column heading of the Rate Per Day column to select the column.
2. From the Insert menu, select Column.
The Insert Column dialog opens.
3. From the Show drop-down list, select Calculation.
4. In the Column Display Name table, select Calculation 1.
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r

IW-%HE 1

Show: | Calculation l-%]

Column Display Name
Calculation 1

Calculation 2
Calculation 3
Calculation 4
Calculation 5
Calculation 6
Calculation 7
Calculation 8
Calculation &
Calculation 10
Calculation 11
Calculation 12
Calculation 13
Calculation 14
Calculation 15
Calculation 16
Calculation 17
Calculation 18

L

Calculation 19

Calculation 20 v

® ( Cancel ) o)

5. Click OK to insert the column.
The Format Calculation dialog opens.

Keep the Format Calculation dialog open for the next section.

11.4 Setting up a calculation

Setting up a calculation
A calculation contains an expression that FastTrack Schedule evaluates to derive a value for each
activity bar. An expression can contain:

- column names - though they must be defined as part of the bar, not row

- operators - like +, -, *, /

- functions - like Awe() for finding the average; or If() for testing for conditions
- values - like the number 20 or text strings like "Bob"

Here, you will define a simple calculation that multiplies the Duration of an activity bar by its Rate per
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Day. This will represent the cost of the activity bar.

Steps:

1. In the Format Calculation dialog, select Duration from the Columns table and double-click it to

enter it in the calculation.

2. In the Operators table, double-click the "*" button to insert the multiplication operator.
3. Use the scroll bar of the Columns table to scroll to Rate per Day.
4. Double-click Rate per Day to insert it into the calculation.

Format Calculati

Enter the formula for your calculation here:

[Duration] * [Rate Per Day]

Resource Cost
Resources Assigned

Iy
1
¥

0

FRI. |

This Calculation Returns:Undefined Functions: [NI Functions Fﬂ
Columns | Operators | Functions |

Mumber 50 ~| [+ ' Mbs(Number) m

Predecessors - m WvelArgl, Arg2, ...)

Priarity i WveDeviArgl, Arg2, ...)

Rate Per Day Cos{Number)

Date(Day, Month, Year)
CatelineDate()

L

)

( Check Calculation
I: Function Reference
(7
A

j [Rate Per Day] is of type:Number

IE Cancel :]E———H

5. Click OK to save the calculation and close the Format Calculation dialog and the Insert Column

dialog.
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March 2012 Api 2012
= @ 47 Astiity Name Duraticn Start Date FinishDate  Rats Per Day W [T w[t Fls[s(m[v wiv rls|sm|7 [w[r F[s|s|[m|7|w
B — 1213 19 /15 16|17 |18 19 |20 21 22 23 |24 25 26 27 28 2% I |31 |1 2 3 |4
P w |Planning 700 tzz 32012 5250.00 50.00{ 1
2 Brainstom | 300 | 3Aanz I Enanz £100.00 e
3 Research I 200 ananz I EGCT 57500 [ —
a Budgst I 300 I 3AEMZ I 32012 57500 1 =— I
5 I ". Development I 8.00 3Maz I 3282 s28500 |
6 Design Z00 G 32012 $12500 25500 ——
e Frolotype | 400 AOAE | W22 38000 32000] || | | I —
P Feview [ 300 [ amemz | m2AnZ 38000 240,00 Tl | (| ——
P |y | Testing | 500 @Mz | Az §17500 450,00, =
PPy (I Fratminary I 200 | aEERz I mzanz $7E.00 w1 [ | I 1 1 | A= |
11 Customer I 300 30z | a2 §100.00 300.00f || I | 1 T e |
12 Final Rewew 000 414z iz 0.00 &
Total: 2300 121514 [ 15 1617 |18 |19 |20 a1 (22 23 2|35 3|27 |2 (20 0 (3|1 [2 3[4

6. Double-click the Calculation 1 column heading to open the Format Column dialog in the Options tab.
7. In the Customized Column Name box enter Activity Costs.

.E"'ﬂp‘ﬁ'ﬂl'lﬁ—| Display Font Summan’es}

Customized Column Name:

| Activity Costs | Use Default )

Default Column Name:

Calculation 1

Column Type Specific Options

';-_?T Stored per bar

E Show in Information Form

[ Define Calculation... }

@ ( Cancel )W

8. Click the Display tab.
9. Enter 60 in the Column Width box.
10. In the Number Display section, select the $ option.
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[{]ptiuns | Display = Font  Summaries

bt

Column Width: f_l

Mumber Display

E Thousands Separators
[T (Negative)
™ s
e
Decimal Places: | 3| @

Example: $-123,456,789.12

® ( Cancel :IW

11. Click OK to apply your changes and close the Format Column dialog.

The values which appear in the Cost column display the result of the calculation you just defined:
Duration * Rate per Day. For instance, the Brainstorm activity bar costs $200 which is the Duration (2
days) times the Rate ($100 per day).

March 2012 Apeil 2012
?‘ﬁ‘l’f Activity Name Duration Start Date Finish Data Rate Per Day Mt w|T|elsle|m[Tw T F[s]s|m|[T|w[T :’s's:u Tlw
N » - —— 12113 12 15 1617 |18 10 20 21 22 33 24 35 36 27 28 26 I 3 1 2|3 a4
p: w |Panning 700 a2z 320112 5250.00 00| 1
2 Brainstorm I 3000 I EGFIH I 3NANE | £100.00 $300.00; I=
3 Research I 300 32 I 3ASZ I 375.00 a0 | | — |
p Budget 300 eIz 012 37500 522500 _—
s | " Development | .00 ERERF | azaMz | $265.00 $810.00 I
P Diesign | 200 |7 sAamz | smtnz | §125.00 ssoool | [ | | [ | | m—
7 Prototype I 4.00 2012 I 22312 I $80.00 sazo.o0f | | (B e ——
8 Rewvew I 3000 I 326112 I 328112 | $80.00 $240.00/ I pr———
9 ". Tesiing I 500 U2BMZ I FTTF] | §175.00 £450.00 (B
P Frelminary I 200 | amanz | azanz | $75.00 $150.00 A= ] |
F' Customer | 300 Iaunz | 4anz | $100.00 $300.00 e f——— |
12 Final Review 000 aianz Az $0.00 >
Total: 2300 TN M 1816 1T 181620 |2 2 3 24 35|26 |27 |2 |2 |30 |1 2] 3|4
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11.5

Defining a summary graph row

Defining a summary graph row

Summary graphs are similar to column summaries-they display the total, average, standard deviation,
minimum, and maximum of values. Instead of summarizing values in a column, however, they
summarize values in the time periods of the timeline graph. They appear directly beneath the timeline
graph.

To define a summary graph row, you must tell it the unit of time to summarize, what data to summarize,
and what summary operation to perform.

Steps:

1.

O©oo~NOOOTEWDN

From the Insert menu, select Summary Graph.
The Format Summary Graph dialog opens.

. From the Summary Units drop-down list, select Weeks.

. In the table, click the first cell in the Data to Summarize section.

. From the drop-down list that appears, select Activity Costs from the bottom.

. In the table, click the first cell in the Summary Operation section.

. From the drop-down list that appears, select Total.

. In the table, click the first cell in the Display As section.

. From the options that appear, select Histogram.

. Click the Fill Color box and, from the Color dialog, choose a shade of blue and click OK.

10. In the table, select the Show Labels option.
11. In the Label Options area at the bottom of the dialog, change the Decimal Places to 0 (zero).
12. In the Left Label box, enter Weekly Costs.
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Summary Units:

Left Label: Weekly Costs
Right Label:

+

Skarts On: | October 3
e 7] Mirror Labels (Copy left label to right label)

| Weeks

l: Insert Mew Summary ) ( Duplicate Summary ) Delete Summary

Data to Summarize | Summary Operation | EZ'_Isq:.%_I:au..r As | Show Labels i
Activity Costs Total Histogram E
Histogram Display Label Options
Outline Color: Fill Color: ™ Thousand Separator
L | 0 (Negative)
Outline Size: Fill Pattern: 0ls BEJ

I | Decimal Places E] [+

[ Apply j[ Cancel j&—ﬂb—a

oo 3!

@

13. Click OK to apply your changes and close the Format Summary Graph dialog.

I March 2012 April 2012
584 Actity Name Duration Start Date Finigh Data Rate PerDay  ActvityCosts[m | 7w T ¢ s|s | m/7/w T ¢ s|s|/m/t/w/r F s/s/u/t/wlr
! 1213 14 15 16 17|16 |19 |20 |21 |22 |23 24 |25 26 7 28|29 @ 3 12 /3 4|3
- v P T FaE B T FE e AGH AR S |
2 | Brainsiorm 300 iz 34z $100.00 $300.00| |
3 | Research 200 EGERF &2 $75.00 322500 —1| | I
Fa| | Budget 3.00 EUTTFS 320112 575.00 $225.00 ede—— | |
P "inamam B.00 EGETRF) zBiz $285.00 $810.00 | I
| | Dezgn 2.00 a2 20012 $125.00 $250.00| — il
¥ | Fromtype [T iz a2aiiz $80.00  $320.00 | —— | [
2 | Revew 300 WEMZ 32612 $80.00 $240.00 |l | ———— il
9 v iTasling 5.00 EUTHF 44z $175.00 $450.00 | ! !
e
10 || Prefminary 200 ECTTRS 29012 57500 $150.00 | i
" | Customer 300 3302 ANz $100.00 $200.00 | [ ——= | [
| | Final Review 0.0 Az iz | $0.00 -
i 720
Weeky Costs Lo 400
200
| Total: 7300 121314 16|16 |17 18| 19 |20 |21 |22 |23 24 |26 |26 |27 |28 (20 |30 31|12 3| 4|6

This summary graph row now shows you the total expenditure per week.

Note:

You can choose to show or hide a particular summary row in the Summary Graph tab of the Define
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11.6

12

121

12.2

Layout dialog.
Finishing Tutorial 8

Finishing Tutorial 8
You are done with Tutorial 8. You now know the basics of defining and using column summaries,
summary graphs, and calculation columns.

To close the Tutor8 file:
1. To close the Tutor8 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:

1. Go to Tutorial 9: Working with Resources.TutorOWorkWResrces
-0r-
Return to the Tutorial Contents.

Tutorial 9: Working with Resources

Working with Resources - Intro

Tutorial 9- Working with Resources
This tutorial shows you how to create resources, display resources, and assign them to activities.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor9.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor9". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Creating a new resource

Creating a new resource

Resources are the people or things that help you accomplish the tasks in your project. Every resource
has a finite amount of time it can be used and effort it can exert. You can define these finite amounts in
work calendars you can design specifically for each resource. Every resource also has a cost attached
to it - whether it is a flat fee, a standard rate, an overtime rate, or any combination thereof. Each of these
elements can be charted and controlled in the Resource View of FastTrack Schedule. You will now
create a new resource.

Steps:
1. From the Views buttons on the toolbar, click the Resource button.
2. Click in the Row 2 Resource Name column.
3. Type Jane Phillips and press the Enter/Return key.
4. Click in the Information Form action column of row 2.
The Resource Information form opens.
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5. In the Type box, choose Consultant from the choice list.
6. In the Per Use Cost box, enter 200.

7. In the Standard Rate box, enter 100.

8. In the Overtime Rate box, enter 150.

Resource Informati

Elnfwmaﬂoﬂ | Work Calendar  Other Columns |

Resource
Resource Mame: Jane Phillips Type: Consultant
Per Use Cost: £200.00 Initials: [P Resocurce Notes:
Standard Rate: |$100.00/h Code:
Overtime Rate: | $150.00/h Group:
Job Title:
Employee |D:
Company: @
Department: @ Marterial Label:
Addresses Phone Numbers Internet
Main: E-mail:
Business: E-mail 2:
Business Fax: Business URL...
Home: Home URL...
Home Fax: IM Address:
Mobile: IM Address 2:
Maobile 2:
@ 10

9. Click the Work Calendar tab.

Note that a typical workday for Jane Phillips is defined as being 8 hours long and lasting from 8 AM to
5 PM (with an hour off for lunch), and that no non-typical workdays (such as a half day for a doctor’s
appointment Jane might hawe) are, currently, defined.
10. Click Close to close the Resource Information form.
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March 2012

J—ﬂ @ -“' Resource Name Man Tuns Wad Thar Fn Sat Eun Man Tues. e Thur Fri Sat Sun Wan
12 13 4 15 gL L1 iL} 19 ) # @ 23 74 & i
{Sont Murphy . | | | | | | | | | |
v o
Percent Work Usage 50 e ——
a
Ori e % o o O [ i Lo 100% | 100% | 100% [ L %
el ! T =
v &l 1
1 Hourly Work Usage 3 B ———
(1]

000k | 0.00h | 000K | 000K | 000K | 0.00K | DOOK | 000K | D00K | 800K | 800K | 800K | 0.00hK | 0.00K | D00
v Protatype [—— T
&8.00 &.00 8.00

| Jane Priips | |
> Pencant Work Usage ID-;"» e [0 Lic o o () e 03 % o o e ‘ 0 o
2 > Hourly Work Usage {)iUU h | 000h | 0.00h | 0.00h | Q00K | 000K | 000K | 000K | 000N | 000K | 000K | 000K | 0.00h | 0.00R | 0.00R
> Assignments QiUU h | 0.00h | 0.00h | 0.00K | 0.00h | 0.00K | OOK | 0.00h | ©.00h | 00K | 000R | 0.00R | 0.OOK | 0.00W | 0.00N

12.3 Assigning a resource to an activity

Assigning a resource to an activity

Assignments link a resource and all its data to a task or tasks in the schedule. The Schedule View and
the Resource View draw from two different pools of information. Assignments act as a bridge between
those two pools of information.

You can create a schedule full of tasks and you can create numerous resources complete with work

calendars and cost data, but until you actually assign a resource to a task, the Schedule View and the
Resource View do not interact.

You will now assign Jane Phillips to work on an activity in the schedule.

Steps:
1. From the Views buttons on the toolbar, click the Schedule button.
2. Double-click the Design bar, located in row 6.
The Information form opens in the Bars>Tracking tab.
3. Click the Bars>Assignments tab of the Information form.
4. In the Resource Name column of the table, select Jane Phillips from the drop-down list.
5. Click in the % (Effort) column; Jane's rates fill in across the row.

You know you intend to split Jane's times between this activity and another, so you do not want to
allocate 100% of her effort to the task "Design."

6. Select the number 100 in the % Effort column, enter 50, so that the new % Effort is 50.
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Row | Bars ]i
Bar ID 4
= Duration: | 4.00 E]
[ Hidden Bar St'rle:[ “.q [ Fixed Duration
[L Tracking Columns  Links | Assignments ;:Ir

M Apply Effort Driven Scheduling (Keeps total work constant) ( Clear Assignments )

... | Resource Name
ﬂ Jane Phillips
Select Resource

| work | % |

(R “Contaur
16.00 50 Flat

| Per Use Cost |
$200.00

Std Rate |

_ | OTRate | Cost |
£100.00/h

$150.00/h $1800...

Totals: 18.00 $1800.00

[ [« [» ] [o1] (close

@

7. Click Close to assign the resource and close the Information form.

March 2012
—jﬁfj Activity Name Duration Start Date FnehDate M| T (W T |6 8|8 |(m|T|w|r|sls|s|lm|lr|w|(T|e|(s|s|M|T|w
121314 18 16|17 18 19 |20 |21 22|23 |24 |25 26|27 26 |28 30 311 |2 |3 4
T T

1 w |Pranning 4.00 FFIF] FCTF]
2 | | Brainstonm 200 anznz anz :_ 11
3 Rezearch 200 4z G2 [—]
4 Budget 0.00 382 R -
&  |Deveiopment 10.00 W82 wzEi2
0 = T T TE .
P Prototype 3.00 W22 H2anz —
s | Review 300 2612 2812 T [ O | e——
Py w [Testing 500 zei12 Az |
“,' Prelminary 200 ANz anz '_. I —.|r.
14 Customer 3.00 3z A3ME | e
12| Final Review 0.00 44Nz Aanz ’ |

Because Jane Phillips is the only resource assigned to the task "Design", the bar expanded to have a Duration
of 4 days so that the bar's total work units of 16 hours could be completed by a single resource working 4
hours a day. The Start Date changed because the bar had a constraint type of Finish On Or After. If Jane
Phillips had been assigned at 100% effort the Duration would have remained 2 days because the 16 work
hours could have been completed in 2 8-hour work days.
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Viewing resource assignments in the Schedule View

Viewing resource assignments in the Schedule View

FastTrack Schedule has a column named "Resources Assigned” that will display, in comma delimited
format, the names of every resource assigned to a given bar. You can also enter a resource directly into

the Resources Assigned column when it is inserted into your layout.

You will now add the Resources Assigned data as a label to the bar style in which the activity "Design"

is displaying.

Steps:

1. Click the Design bar in row 6 to select it.

2. From the Format menu, select Bar Styles.
The Format Bar Styles dialog opens.

. Click the Schedule View Labels tab.

NOoO ok~ Ww

. Select Resources Assigned in the Shown Columns table.
This makes formatting options available.

. From the Show Label On Part drop-down list, select Schedule End Point.
. In the Available Columns table, scroll down until you can see Resources Assigned.
. Select Resources Assigned and click Show to send it to the Shown Columns table.

8. In the Offsets area, enter -2 in the Vertical box and 10 in the Horizontal box.

Format Bar Styles

Bar Style Type:
[ Bar B‘
Aesources Assigned
Component:
—_— Scheduled B
Tr———— Component Options
e |
[r—————]
| I [ Parts | Schedule View Labels = Resource View Labels  Alignment ]
Show Label on Part: | Schedule End Point ] ( Format Label...
f Label Data
= Available Columns Shown Columns
- Priority - —Sh = Resources Assigned
v Resource Cost g
Revised Duration m Hide )
Revised Finish Date i
Revised Finish Time Hide Al
[ Copy )|
Paste
i Dffsets
[ New :] Vertical: —2| [ Horizontal: 10] I2]
[ Delete :]

( Apply j( Cancel jf—@lﬂ——)
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9. Click the Format Label button.
The Format Bar Label dialog opens.
10. Click the Border tab.
11. In the Line area, click the Color option and choose black from the color wheel in the Colors dialog.
12. In the Line area, enter 0.25 in the Size box.

Format Bar Label

[ Font | Border | D'rspia!_.r]-

Background Line Shadow

Color: |:| Color: |E| Color:

Margin: ol b Size: (.25 '?' Size: 0 'H'

E Transparent
Example

Corner

Radius: I:I I?I Aosouces Assignod
Options

] Apply Border Attributes to All Bar Labels

@ ( Cancel ) (w0

13. Click OK to save your changes and close the Format Bar Label dialog.
14. Click OK to close the Format Bar Styles dialog.

The resource you assigned to this task now displays as a label at the end of the Design bar. Because
the Prototype bar in row 7 contains the same bar style and has a resource assigned to it, a label
appears for that bar also.
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__,; @ f Activity Mame Duration
1' | | 4 Eii'!a'uhr!g 4.00
2 Braingtorm 2.00
3 Research 200
4 Budget 0.00
5 v | Development 10.00
6 | Design 4.00
T Prototype 3.00
8 Review 3.00
P w | Testing 5.00
10 | Prelminary 2.00
14 | Customer 3.00
12 Final Rewew .00

Viewing resource subrows

Viewing resource subrows

Start Date
ERFIF]
Jahz
ez
Henz
WHishz
nanz
w212
262
Jzanz
2Bz
Fannz

Az

Finish Data

B2
ianz
EGET
ez
Jzmi2
20012
Haanz
H2ahz
Az
w2912
A3NE

4lanz

M T

1% 13

Wi T|[F|&
H 15 18 17

-

March 2012
M| T|W|T|F |5 E|M|T|W|T|F|B|5 M|T|W

1619 |20 |29 |22 |23 M |35 26|27 (20|29 30 (3|1 |k |3 |4

There are three subrows in each row in the Resource View:
- The Percent Work Usage subrow displays a graph representing a resource’s currently allocated time
as a percentage of the overall available time for that resource.
- The Allocated Time Usage subrow displays a graph representing a resource’s currently allocated time
in respect to the Work Units. The name of this row changes to match the Work Units you have set in
the Document Preferences dialog. If your Work Units were set to Days, this subrow would be titled Daily

Work Usage instead of Hourly.

1} ! .
— ars Phi_lipsism‘

FR— Euf.h\.lrn"\}‘
|

[E S S
M
R

|
|
| .

- The Assignments subrow displays the activity bar or bars to which a resource is assigned. Assignment
bars display just as they do in the Schedule View. Links, howewer, do not display.

Steps:

1. From the Views buttons on the toolbar, click the Resource button.

All three subrows of row 2 are collapsed.
2. Click the Expand All button in the Format toolbar. [%]

You can now view the Usage graphs and assigned bars for Jane Phillips.

4; @ !- Resourca Name
94 | Hourly Work Usags
v Prototype
|Jane Prillips
v
Percant Work Usage
2 v |
Hourly Work Usage
bl Design

[

ena ok B

Marcn 2012
Man Wad Thar En Sat Sun Man Tuns: Wad Thur Fn Sat Sun Kan
12 4 16 1w 14 1w 0 # bl # 4 i L]
D00k | 0.00h | 000K | 000K | O.00R | 000K | 000K | ©00h | 000K | 800K | 800K | 800K | 0.00K | 0.00h | O.00N
Developmant:-Protatyps
8.00 8.00 8.00
e ——
0% 0 500 5% o 0 50%. S0 e O | 0% 0% %% O
0j00n | 0.00h | 0.00K | 400K | 400h | 0.00h | 0.00h | 4.00m | 4.00n | 000n | 0.00n | 0.00h | 0.00K | 0.00K | 2.00R
Dowolcpmant Dasign
4.00 4.00 Loz i 4.00 4.00
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12.6

13

13.1

13.2

13.3

Finishing Tutorial 9

Finishing Tutorial 9
You are done with Tutorial 9. You now know the basics of defining and assigning resources.

To close the Tutor9 file:
1. To close the Tutor9 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:

1. Go to Tutorial 10: Using FastSteps.
-or-
Return to the Tutorial Contents.

Tutorial 10: Using FastSteps

Tutorial 10- Using FastSteps

Tutorial 10- Using FastSteps
This tutorial illustrates how to apply and create FastSteps.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor10.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor10". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

What are FastSteps?

What are FastSteps?

FastSteps are a scripting ability, built into FastTrack Schedule. FastSteps allow you to automate
repetitive management tasks by grouping a series of commands into a single sequence that you can
then initiate with a mouse click. FastSteps are available in the Schedule, Resource, and Calendar View
and their Print Preview windows.

Each member of a project team can have a FastSteps sequence to suit his or her needs. You can

create different sequences for every version of the schedule you would like to print, thus creating reports.
There is no limit to the number of uses you can find for this powerful tool.

Applying a FastStep

Applying a FastStep
In the Schedule View, existing FastSteps can be applied directly from the FastSteps submenu of the
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Schedule menu.

Steps:

1. From the Project menu, select FastSteps, and choose Restore Master Schedule from the

submenu.

The View is switched to Schedule View, the Main Layout is applied, the Master Range is applied and all
hidden rows are restored and returned to the Master Sort order.

Jﬂ @4€ Activity Mams Duration
B | | |Pranning | 4.00
2 Branstorm 2.00
3 Research 2.00
| 4 | Budget 0.00
5 v Deveicpment .00
6 Design 2.00
7 Frototype 3.00
8 Rewiew 3.00
9 v Testing 5.00
| 10 | Preliminary z.00
1 Customer .00
| Final Review 0.00

X}

Creating a basic FastStep

Creating a basic FastStep

Start Date

22
iz
aanz
31612
a2
ez
w2z
2612
3zai2
328012
3012
anz

Finigh Data

31612
a1anz
B6ME
T
328z
T
w2
T T
Az
420112
Az

ANz

March 2012 Agril 2012
S| M|IT|IW|T|F|S(S|M|T| W|T|F|S| & |M[TIW T|F|(S|S|M|TKW
W12 13 |14 15 16 |17 18 [ 1B 20 21 |22 23|34 26 2627 (38|29 I 31|12 | 3 |4

————
——
e

Custom FastSteps are created in the Define FastSteps dialog.

Steps:

1. From the Project menu, select FastSteps, and choose Define from the submenu.

The FastSteps dialog opens.

2. Click the New button.

The Define FastSteps dialog opens

3. Enter My Exports in the FastSteps Name box.

4. From the Commands table scroll down to Schedule.Export Picture and click Add to send it to the

FastStep table.

5. In the FastStep table, click Schedule.Export Picture.

6. Click the Setup button that appears in the Options area.

7. In the Export as Picture dialog, select the File option

8. From the File Type drop-down list, select Portable Network Graph (PNG).

9. Click Browse.

10. In the sawe dialog, navigate to your Desktop.

11. Enter Schedule View as the filename.
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Destination

® File () Clipboard
Browse... ScheduleView.png

File Type
| Portable Network Graphics (PNG) s
JPEG Quality to Compression Factor (Highest Factor, Best Quality): 99 r:!
Example:
(=) T e
. . B G Trsmdes ' & m 0w 7 8 8 8 m 7 w8 s om o m f om0 @ almom fiw b
o 18 CIC SN OO DNUNE O SO SIS T O O I T R R A |
= [ ] T -
e Fe ] wind il e
= oo B i e B
m [ ] [STeF] 1 t
Sangn ra el W B  E— I
Tenrga (5] P L =155 — :
L. =] Jawm F- ] T 17 m—
g ] amm wana | —————
L — T s Fe.TH PRl |
s e | = : § |
] EHs 7] -

@ ( cancel ) oK)

12. Click Save.

Keep this dialog open for the next section.
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FastStep Name: my Exports

Commands Faststep
Schedule.Show Qutline Level = Schedule.Export Picture [Schedul. .

Schedule.Export Data

Schedule . Export Html

Schedule . Export MPX
Schedule.Export 1Cal [ Remove )
Schedule.Export XML
Schedule.Export Picture
Schedule Finish Date

Description Options
Schedule.Export Picture: Exports a
picture of the Schedule View. Choose
“Setup” to configure the Export Picture
options.

@ ( Cancel ) oK)

13.5 Creating a basic FastStep (contd)
Creating a Basic FastStep (cont’d)

Steps:

1. Click OK to close the Export as Picture dialog.

2. In the Commands table, scroll down to Calendar.Export Picture and click Add to send it to the
FastStep table.

. In the FastStep table, click Calendar.Export Picture.

. Click the Setup button that appears in the Options area.

. In the Export as Picture dialog, select the File option

. From the File Type drop-down list, select Portable Network Graph (PNG).
. Click Browse.

. In the sawe dialog, navigate to your Desktop.

. Enter Calendar View as the filename.

10. Click Save.

11. Click OK to close the Export as Picture dialog.

©oOo~NO O~ W
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FastStep Name: my Exports

Commands I FastStep o
Calendar View — Schedule.Export Picture [Schedul... |
Calendar.5how All Bars Range Calendar.Export Picture [Calenda. ..

Calendar.Apply Range
Calendar.Export Picture
Resource Wiew m
S
i
v

Resource.Show All Bars Range
Resource.Apply Range

Resource Apply Layout

Description Options
Calendar.Export Picture: Exports a
picture of the Calendar View. Choose
"Setup” to configure the Export Picture
options.

® { Cancel }w

12. Click OK to sawe the FastStep and close the Define FastSteps dialog.
13. In the FastSteps dialog, make sure My Exports is selected and click OK.

FastSteps
" Expurts_ kil Wi
Restore Master Schedule
Autofit Schedule - Activity N._.
Milestones

| Menu | Break |

Duplicate...

Completed Tasks
Delete...

Upcoming Tasks
Incomplete Tasks
Cost Report

Resource Cost Report

AEEEEEEERE
000000000

® [ Close jf'-—ﬂl—a

The Schedule View and Calendar View files appear on your Desktop.
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13.6

14

14.1

14.2

Finishing Tutorial 10

Finishing Tutorial 10
You are done with Tutorial 10. You now know the basics of working with FastSteps.

To close the Tutor10 file:
1. To close the Tutor10 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

To start the next tutorial:

1. Go to Tutorial 11 - Consolidating Files.
-or-
Return to the Tutorial Contents.

Tutorial 11: Consolidating Files

Tutorial 11 - Consolidating Files

Tutorial 11 - Consolidating Files
This tutorial shows you how to consolidate separate subordinate files into one master file.

To open the practice schedule file to be used while taking this tutorial:

1. In FastTrack Schedule, go to the Help menu, select Tutorials, and choose Tutorial Practice Files
from the submenu.

2. Select the FastTrack Schedule file Tutor11.

Important:

If you cannot locate the Tutorial folder on your computer, go to Find and search for "Tutor11". If this
produces no results, check with your System Administrator to make sure the Tutorial folder was
included when FastTrack Schedule was installed on your computer.

Understanding Consolidation

Understanding Consolidation

You can easily consolidate your FastTrack files into one master file to analyze a big picture view of your
data. Whether you want to see all the separate components of one larger project, or see every project
your company is currently working on, Consolidation allows you to do so. Consolidation works across
platforms so consolidated files can originate from either a Mac or Windows operating system.

Master file - the file you create by consolidating existing files is called a master file. A master file can
never be inserted into another file or into itself.

Subordinate file - a file that is inserted into a master file is called a subordinate files.

Subordinate files must be accessible, either on the hard drive or by network, and openable. The master
file’s user must have read access to a file to insert it.

Important:
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Consolidated subordinate files are not live. There are no automatic updates. When data changes in
a subordinate file the changes do not appear in the master file until you choose to refresh the data from
that subordinate file. Changes you make to data in the master file must be manually applied to the
appropriate subordinate files.

A key to consolidation is the project Work Calendar. All subordinate files must have the same
project Work Calendar as the master file. If you try to insert a file with a different project Work Calendar
that file will be ignored and not inserted.

Changes to data in the master file are for analysis only and do not affect the subordinate file. If you
decide that you want to apply changes you have made in a master file, you must open the appropriate
subordinate files and manually make the changes there.

The following data is consolidated:

- All columns — except calculation columns
- Bars and bar styles

- Pictures, text boxes and legends

- Links

- Assignments

- Pointers

Any conflict in data between a subordinate and the master file results in that data being excluded from
consolidation.

If a column in a subordinate file is formatted to save data Per Bar and the same column in the master file
is formatted to save data Per Row, that column will not be included in the consolidation.

Consolidation is data driven, not visual. Formatting related information will not be consolidated.
Formatting is originally determined by the master file’s preference settings. You can edit Filter, Sort,
Layout, Range, FastSteps and format settings in the master file, but the changes will not be applied to
the subordinate file unless you manually apply them.

Resources do not get deleted from the master file even if future updates of the subordinate file in which
the resource originated no longer includes that resource.

You can consolidate subordinate files that have different Resource Work Calendars defined for the same
resource.

14.3 Defining Consolidation

Defining Consolidation

To define the subordinate files to be consolidated:
1. From the File menu, choose Consolidation and select Define.
The Define Consolidation dialog opens.
2. Click Add.
The Open dialog opens.
3. Navigate to the folder containing the FastTrack Schedule Tutorial Practice Files.
4. Select the file Tutor11-C1.fts.
5. Click Open to close the navigation dialog and add Tutor11-C1.fts to the table in the Define
Consolidation dialog.
6. Click Add.
7. Navigate to the folder containing the FastTrack Schedule Tutorial Practice Files.
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8. Select the file Tutor11-C2.fts.
9. Click Open to close the navigation dialog and add Tutor11-C1.fts to the table in the Define
Consolidation dialog.

| File Name | Add
1 Tutorll-Cl.fts

2 Tutorll-C2.fis

Remowve

Locate

Update

10. Click Update All to consolidate both files into the master file Tutor11.fts.

{#) Files are subprojects and have a common Project Finish Date.

D Files are projects and have separate Project Finish Dates,

@

(

Close

O updateat )

| March 2012 April 2012
ﬂeﬁﬂ Activity Name Duration Start Date FinishDate [ [T [w[T[f[s[a{m|[r|w|[r|[rla][s[mir[w|[r[el[s|s[m[r|w[r][e[s]s]n

| 1213 141518 17 181920 21 (2225 24 25(20 27 28|29 (30 1 [2[3 4 5 6|7 8|9

= | e | .

2 & v [T 600 32z a9z i

3 I w | Panning 600 3212 ez | I

4 Branstorm 200 31201z ananz I=L I T [

5 Research 200 34Nz EUTH

€| Budget 200 G anonz I _\1__

¥ & v | Tueriiad 16.00 348z 482

PY | w | Deveiopment 8.00 EGETH ELITF]

P Dasign 200 a8z 3202 -

10 | Frolotype 200 w2101z EVERF I __.,\

" Review 3.00 32812 ez

12 |y | Testing 8.00 282 481z

13 Fraliminary Z00 320012 a2 I I

" Customer 3.00 Az aiaiz ""‘M—-T\h |

15 Final Review 300 45012 iz | S 5

You can update files by going to the File menu, choosing Consolidation and selecting Get Updates.
If any saved changes have been made to one or more of the consolidated subordinate files, they will then
display in the open master file.

Finishing Tutorial 11

Finishing Tutorial 11
You are done with Tutorial 11. You now know the basics of consolidating files.
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To close the Tutorr11 file:
1. To close the Tutor11 file, from the File menu, select Close.
2. Click No to close the schedule without saving your changes.

Congratulations! You have completed the last tutorial. You should now have a good idea of how to use
FastTrack Schedule’s basic scheduling operations as well as some of its most powerful features.

If you want to see examples of how you might you use FastTrack Schedule, open some of the example
schedules installed with this application. Or, dive right in and start scheduling your own projects. And
remember, as you continue to use FastTrack Schedule, help is only a click away.
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Schedule View 78
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